summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 22:33:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 22:55:38 +0100
commit65b60b6d3f204a78f9a75b87fd31640bcca0e77e (patch)
treef98b5f7ff4bb4ba2a109792eeed102f03efbef29
parentdev-python/lmdb: Bump to 1.3.0 (diff)
downloadgentoo-65b60b6d3f204a78f9a75b87fd31640bcca0e77e.tar.gz
gentoo-65b60b6d3f204a78f9a75b87fd31640bcca0e77e.tar.bz2
gentoo-65b60b6d3f204a78f9a75b87fd31640bcca0e77e.zip
dev-python/sphinxcontrib-spelling: Bump to 7.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 3f8598b49bb2..75c6e3d66352 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-spelling-7.2.1.tar.gz 49584 BLAKE2B 7211acfe344b157c0d44f356aef4c31fabcb1b30256cec1693fa67d2652d80c8f3657441c193f82ef26e0e7acd7d141732bef0704462a292355d70a18ab3c2be SHA512 e9b9709b627545e1191d64753c97c0cf65e100d5379e7cc1da46faf9c5d5ea0eeb6c7aafe99331f9518488fb0801c245e0c1fa9853360bb6cf373515a4fed2ed
DIST sphinxcontrib-spelling-7.3.0.tar.gz 49853 BLAKE2B 3bf7c6433a5de6b109891f1546f109ce7dc5870c0932f49a2dfbc1356c365ba48f885af21e0873284112d8b7b67dbb24730373a16e6786ba7e15f2bc23dc8360 SHA512 25b1902547e4ed172ec437aca0868f458c60aab8dacbeeec7ec1c57a93716672986b815aadb9c129fc6b068b5e4d7e96f6200160c0b688e67314abf290e4ff17
DIST sphinxcontrib-spelling-7.3.1.tar.gz 51104 BLAKE2B 8d757b492ce5bcb103bc604923da928f0440d4d0b882743d14b60fef21cfb423ea93a1e79f309b7cf27e8385ac94c01b24163a17407609ee20b9ec82dff63f62 SHA512 53f2532ff31a82c1cf568400a6066f319da3331c960446478bcd37e9293f4d080061b9c4914ac308e89878f432b6573ff782c5faba0f557384da55f202e68479
+DIST sphinxcontrib-spelling-7.3.2.tar.gz 51813 BLAKE2B 7c96f3b102fa33ea4d9e35100930a157200a1c01c51d8ec5145c45c5a24e3b5de35f6c4669177363c6098cb96275e10c39ff660c36d209cb6fa658e50cb8e169 SHA512 043a50f694366de4a3aedc24ca2ea7d89c85087097264f4e4fc860f68a3df5a67f19ec7172e4a67074377846d013d24edecd751885136c7263bc30b034c0f0e9
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.2.ebuild
new file mode 100644
index 000000000000..ad0ee88aa3d2
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+# The doc can only be built from a git repository
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}