summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-30 18:16:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-30 18:37:26 +0300
commit65df71168d095bf95a10aaf58072503d2429b809 (patch)
tree8c861eac4500c964ba672c7c169d3920c2f68a66
parentdev-python/urwid: fix docs generation (diff)
downloadgentoo-65df7116.tar.gz
gentoo-65df7116.tar.bz2
gentoo-65df7116.zip
dev-python/urwid: add 2.1.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-2.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index b500cab78479..6e038e00a764 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -1 +1,2 @@
DIST urwid-2.1.1.tar.gz 633082 BLAKE2B 93393cc9f8e755cf2e25119f26487e062ab145ff4c966c69ad0b153cc2a286aac4f70be9b7e82c57f644fb850f70c88c0c9562cf1c07dcdd427e0afe409a01b0 SHA512 08fc51205f0adeea0ecce876ca17d921961b665894aef440fd826ef0f8b9230cd8d22c5db85fcf4e227f8e70841e3439860e5035ff874b8d0c1834111c3a97db
+DIST urwid-2.1.2.tar.gz 634621 BLAKE2B ce274820c27708fd0b10f22359923316576b895f6888c9b174b42dedcd551353b6c3ba797c68d61a082ecf23b8f0108a58454bdb44806e33b74d9e6e5bd28537 SHA512 f102bdde5f5d39d4bce455020bbe4f18290589da0750a3b15b1e2bc8acf8a405f02295d7efa3009877801a36bfbfade92ec963086122e9b133db137d816a1ea5
diff --git a/dev-python/urwid/urwid-2.1.2.ebuild b/dev-python/urwid/urwid-2.1.2.ebuild
new file mode 100644
index 000000000000..8e5ca05854ae
--- /dev/null
+++ b/dev-python/urwid/urwid-2.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="http://urwid.org/ https://pypi.org/project/urwid/ https://github.com/urwid/urwid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # optional tests broken by modern tornado versions
+ sed -e 's:import tornado:&_broken:' \
+ -i urwid/tests/test_event_loops.py || die
+
+ # Fix doc generation
+ sed -e 's/!defindex/layout/' -i docs/tools/templates/indexcontent.html || die
+
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}