summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-08 05:30:05 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-08 07:57:50 -0500
commit65ef3461df68e9812a663fad4e326edca295253a (patch)
tree05868a6caff04eb07263bd48e3caa6047b091d20
parentgames-emulation/pcsx2: drop 1.7.5214 (diff)
downloadgentoo-65ef3461df68e9812a663fad4e326edca295253a.tar.gz
gentoo-65ef3461df68e9812a663fad4e326edca295253a.tar.bz2
gentoo-65ef3461df68e9812a663fad4e326edca295253a.zip
games-emulation/pcsx2_patches: drop 0_p20231117
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-emulation/pcsx2_patches/Manifest1
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index b3be70918621..1e7ed0b3b289 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1,2 +1 @@
-DIST pcsx2_patches-0_p20231117.tar.gz 638316 BLAKE2B 331d2ceec0c9e10d5b8cf344a432561173083a37000f8fa3f3890e001a588884e7253bf93d5ca624d36489c9e2f4c0a865de3357d415e9f25d422bedd1106b93 SHA512 7a55a70627b045fd426e88c94e72f191adf72ee01917f9963d4bbfc4a9f96e361efb7bb86487aec4067886458779b42228fd0c5c62f2f07dfada99ba89550d8c
DIST pcsx2_patches-0_p20231217.tar.gz 647767 BLAKE2B a82211d3a31ee3475d2047ad4c25cc247003b15f8132c0e0fa1c144fff3ea59f0806409aeb9a1128697aee2453110d2da50e9577067d068879a885477b04dc3a SHA512 411431fa80a0a221c7b336ebb84ce9b0c078ff75c2cc79b5e31c9b5fc505f9ecec8b371c142a6be6802e2070ae57758c65df34d24d5392fb9f4065a276b32610
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild
deleted file mode 100644
index d90b0959a70f..000000000000
--- a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit python-any-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
-else
- HASH_PCSX2_PATCHES=d6195fdc69add33dcc29fd973568896a8e8e6247
- SRC_URI="
- https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
- -> ${P}.tar.gz
- "
- S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
-HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
-
-# these are normally distributed by upstream with PCSX2 which is GPL-3+
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="${PYTHON_DEPS}"
-
-src_compile() {
- # upstream uses a constantly replaced "latest" patches.zip (currently no
- # real releases), and github's .zip archives cannot be used either due to
- # having the patches/ subdirectory -- so we use a snapshot and repack
- # (could use app-arch/zip, but python is more likely to skip a dependency)
- ebegin "Creating patches.zip"
- "${PYTHON}" - <<-EOF
- import pathlib
- from zipfile import ZipFile, ZIP_DEFLATED
-
- patches = pathlib.Path("patches/")
-
- with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
- for file in patches.iterdir():
- archive.write(file, arcname=file.name)
- EOF
- eend ${?} || die
-}
-
-src_install() {
- insinto /usr/lib/pcsx2/resources
- doins patches.zip
-
- einstalldocs
-}