summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 00:51:14 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 00:53:24 -0800
commit6614c968bd3506b7f048afd0d71ff6ffbda99629 (patch)
treeeadedec1e70f8c337b7923c3213bf40e77f872b2
parentsys-fs/hfsutils: Export CC (diff)
downloadgentoo-6614c968bd3506b7f048afd0d71ff6ffbda99629.tar.gz
gentoo-6614c968bd3506b7f048afd0d71ff6ffbda99629.tar.bz2
gentoo-6614c968bd3506b7f048afd0d71ff6ffbda99629.zip
x11-misc/tdrop: new package, dropdown window creator
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--x11-misc/tdrop/Manifest1
-rw-r--r--x11-misc/tdrop/metadata.xml11
-rw-r--r--x11-misc/tdrop/tdrop-0.3.0.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/tdrop/Manifest b/x11-misc/tdrop/Manifest
new file mode 100644
index 000000000000..cdd596c316d8
--- /dev/null
+++ b/x11-misc/tdrop/Manifest
@@ -0,0 +1 @@
+DIST tdrop-0.3.0.tar.gz 19495 BLAKE2B 5f72090e6ccacaa4f708715cb1a2eb43bb8acec79f43301da67dbe0a8d81637806603d06b9ad0b2815e8aea1f481271f5b8f8adddba60079ad48ec621f8e8e8f SHA512 3e1c30e42ce96570fabd43b89fd9f17a23d74c4943ef9ab5d1edb4967ffa6c4c0259df4449ef2a18b396d1057f4a19a413fec817ff708d3e41906695cebb67ca
diff --git a/x11-misc/tdrop/metadata.xml b/x11-misc/tdrop/metadata.xml
new file mode 100644
index 000000000000..e22c540bc283
--- /dev/null
+++ b/x11-misc/tdrop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">octuid/tdrop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/tdrop/tdrop-0.3.0.ebuild b/x11-misc/tdrop/tdrop-0.3.0.ebuild
new file mode 100644
index 000000000000..1031384a291e
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}