summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 06:25:34 +0100
committerSam James <sam@gentoo.org>2023-05-31 06:25:39 +0100
commit661cba6ac68bc4076eed76b801d2c895abedc52d (patch)
treecefc60de238caafd87bd2d54039d6d505d1c5a50
parentwww-servers/civetweb: drop 1.12 (diff)
downloadgentoo-661cba6ac68bc4076eed76b801d2c895abedc52d.tar.gz
gentoo-661cba6ac68bc4076eed76b801d2c895abedc52d.tar.bz2
gentoo-661cba6ac68bc4076eed76b801d2c895abedc52d.zip
x11-terms/xterm: add 382
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-terms/xterm/Manifest2
-rw-r--r--x11-terms/xterm/xterm-382.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 549fd829d680..87f16a4f539b 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -4,3 +4,5 @@ DIST xterm-380.tgz 1537369 BLAKE2B ef4114ef3e9a2c731839689f62a7aab9549302c4d8646
DIST xterm-380.tgz.asc 729 BLAKE2B 1dda140314e7f08c961f697f0fa17454d4dab2c909b3b21203503ee295ac17aa91b91c27eff38b81586b89ccbafef543cface7f6c600e62f89a9c35a4dbde4a6 SHA512 c3ce95c6b93daecab419b50c4bdb5576599ba1ba291e24217264ff88c42d6c46bb91d10bdb8b990168814c5c771bfe2b4e2879e2ce9d279cab73baac6c2addad
DIST xterm-381.tgz 1536598 BLAKE2B 44a94e893fa8696e58e7246c2800799ca85b4f099f059e62b9f6af98793ba0106e90003d961c318d67efbbd3dcb249f7449e9936aeeb789153f456479485891a SHA512 8cfcfc1f5c5404bcee56265765e489db676838fed6c3182fcc078c55952d6ac76835705d2fa414098fb7e373acb6229f0f5b44150a43844990c58d69cdeec591
DIST xterm-381.tgz.asc 729 BLAKE2B d6b866eb09c42dea4956bc6997f752b3a59ae0477275e5919abd9420d151cc094cc99b06088026991d76f254bc84f637dd67dc9191870cf88ba9f48a5d74651b SHA512 05217da892f6b6261c33359b1905b97b0164bbbf155be4e516cd624e5afc9dfa8b89a46f1ae302c7ed486ad466c19200becda556c35fa09fd6a932b634cb9b10
+DIST xterm-382.tgz 1536637 BLAKE2B 50e538f9ad0735da9c108aca2ccd4e5f14c3aa923fa932952098731e2c68658eaa3f5a35d65468db18b6cabef2f0da5ff8292da9d863a4254f7ca8f4d92e363d SHA512 52780430928d071a131ba9d79ca6915d9f627e82a527f5b0c1eac8e05cea62294631e4a6f27a29e5fa046e3b15c3744e532322e547f4a6a01d05779f0807b8b5
+DIST xterm-382.tgz.asc 729 BLAKE2B 08d3c637ab1d922c951abda0306e07c3ce51d41d4f916fbc01eb2975ac294417bc4f3f07ccadf7332a8c6547bd6e373bc300a3ce6e0fb21abb8a1699f8bad64e SHA512 d399cb16dcb8b0c6c6eb998d2d37c445079d57d46e5ec3e8ca94479443a817419dc1051181b31e8f478ab8910773477de19d6b783439454fb259f135390a8bd1
diff --git a/x11-terms/xterm/xterm-382.ebuild b/x11-terms/xterm/xterm-382.ebuild
new file mode 100644
index 000000000000..175692654251
--- /dev/null
+++ b/x11-terms/xterm/xterm-382.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit desktop flag-o-matic toolchain-funcs verify-sig xdg
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+DEPEND="
+ kernel_linux? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+DEPEND+=" x11-base/xorg-proto"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+src_configure() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+
+ # bug #454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-icon-theme=hicolor
+ --with-icondir="${EPREFIX}"/usr/share/icons
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ sed -i -e 's/_48x48//g' *.desktop || die
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
+}