summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-01 23:23:11 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-01 23:23:34 +0200
commit66275d642d04ee61f6e6369fae47ca9cade90a12 (patch)
treeee2eb695d354a6ba3fe6afd95596fdc6781f5742
parentnet-misc/youtube-dl: Old (diff)
downloadgentoo-66275d64.tar.gz
gentoo-66275d64.tar.bz2
gentoo-66275d64.zip
net-misc/youtube-dl: Version 2019.07.02
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.07.02.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index be28e21e2b83..da418d24dbae 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1 +1,2 @@
DIST youtube-dl-2019.06.27.tar.gz 3170966 BLAKE2B f105f246e0f3e7edac2ada6685475d0b35cb3bcba39e36dbccbddf58d5103c25d93c6fe0ec8cf3fb64d35d53ab12283450184a414f551b1937c4547f2b441c4e SHA512 f59f6633b5f516736403e48f21e29684447fd12424d94423b7acca6809e9531ecf2922eec528ba7e8d9b7c62d12201c3194fccce95121ef4fc5430a8f64d4e6c
+DIST youtube-dl-2019.07.02.tar.gz 3171559 BLAKE2B dd3b672f672ace05f433cbf539a1f00b69000cdfae472dcf1f2c22f4c9414d8e2ca542399e5abf084d197f1f04bbe9dd1651943d8e7f81369d3b3dede6617837 SHA512 5dd4f3b024008d8722e0554f9143d1cbea3ea52971a2a5ff338585f38eb8c8ec256b83249e0145e9bf0012cbe440acf5872edd127d30a0c8803d8d0e74d0ba11
diff --git a/net-misc/youtube-dl/youtube-dl-2019.07.02.ebuild b/net-misc/youtube-dl/youtube-dl-2019.07.02.ebuild
new file mode 100644
index 000000000000..a8b1afbfc11a
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.07.02.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}