summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-29 10:08:25 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-29 10:09:15 +0100
commit6628308541c73537f87e1c3cdb21fb85edaa27fa (patch)
treefaefdf849fce398cce0a3cd44e02bbb091edb2d6
parentnet-misc/youtube-dl: Version bump. (diff)
downloadgentoo-66283085.tar.gz
gentoo-66283085.tar.bz2
gentoo-66283085.zip
sci-libs/scipy: Build sequential if python3.5 is involved
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573148 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-libs/scipy/scipy-0.17.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/scipy/scipy-0.17.0.ebuild b/sci-libs/scipy/scipy-0.17.0.ebuild
index 5f5776b10b07..098222392ce4 100644
--- a/sci-libs/scipy/scipy-0.17.0.ebuild
+++ b/sci-libs/scipy/scipy-0.17.0.ebuild
@@ -109,7 +109,9 @@ python_prepare_all() {
python_compile() {
${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile -j $(makeopts_jobs) ${SCIPY_FCONFIG}
+ distutils-r1_python_compile \
+ $(usex python_targets_python3_5 "" "-j $(makeopts_jobs)") \
+ ${SCIPY_FCONFIG}
}
python_test() {