summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-01-28 19:18:46 +0100
committerFabian Groffen <grobian@gentoo.org>2024-01-28 19:20:00 +0100
commit662e4585eef68252845c897c989764dddd350141 (patch)
treea8d8dc38048e00b9d81b27e7523861e5fac5ebe5
parentdev-db/lmdb: QA: remove empty global assignment (diff)
downloadgentoo-662e4585eef68252845c897c989764dddd350141.tar.gz
gentoo-662e4585eef68252845c897c989764dddd350141.tar.bz2
gentoo-662e4585eef68252845c897c989764dddd350141.zip
mail-mta/exim-4.97.1-r2: update upstream patches for pcre2 memory usage
Bug: https://bugs.gentoo.org/922780 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--mail-mta/exim/exim-4.97.1-r2.ebuild (renamed from mail-mta/exim/exim-4.97.1-r1.ebuild)0
-rw-r--r--mail-mta/exim/files/exim-4.97.1-memory-usage-bug-3047.patch210
2 files changed, 190 insertions, 20 deletions
diff --git a/mail-mta/exim/exim-4.97.1-r1.ebuild b/mail-mta/exim/exim-4.97.1-r2.ebuild
index 8ac924524bb1..8ac924524bb1 100644
--- a/mail-mta/exim/exim-4.97.1-r1.ebuild
+++ b/mail-mta/exim/exim-4.97.1-r2.ebuild
diff --git a/mail-mta/exim/files/exim-4.97.1-memory-usage-bug-3047.patch b/mail-mta/exim/files/exim-4.97.1-memory-usage-bug-3047.patch
index f141d08bb7b4..75e5d1a42781 100644
--- a/mail-mta/exim/files/exim-4.97.1-memory-usage-bug-3047.patch
+++ b/mail-mta/exim/files/exim-4.97.1-memory-usage-bug-3047.patch
@@ -1,36 +1,60 @@
-https://bugs.exim.org/show_bug.cgi?id=3047
-https://bugs.gentoo.org/922780
+From b4e7527561f1c68b821d5cf25efe29ae63d1d434 Mon Sep 17 00:00:00 2001
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Thu, 25 Jan 2024 17:48:43 +0000
+Subject: [PATCH] Appendfile: release regex-match store every thousand files.
+ Bug 3047
-diff --git a/src/src/transports/appendfile.c b/src/src/transports/appendfile.c
-index ec41ca035..91b353079 100644
---- a/src/transports/appendfile.c
-+++ b/src/transports/appendfile.c
-@@ -153,6 +153,10 @@ static const char *mailbox_formats[] = {
- (!ob->quota_warn_threshold_is_percent || ob->quota_value > 0))
+From 35aacb69f5c839a4b77158464e401d86eb422ed6 Mon Sep 17 00:00:00 2001
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Fri, 26 Jan 2024 21:58:59 +0000
+Subject: [PATCH] ACL: in "regex" condition, release store every thousand
+ lines. Bug 3047
+
+
+diff --git a/src/src/exim.c b/src/src/exim.c
+--- a/src/exim.c
++++ b/src/exim.c
+@@ -49,6 +49,8 @@ optimize out the tail recursion and so not make them too expensive. */
+ static void *
+ function_store_malloc(PCRE2_SIZE size, void * tag)
+ {
++if (size > INT_MAX)
++ log_write(0, LOG_MAIN|LOG_PANIC_DIE, "excessive memory alloc request");
+ return store_malloc((int)size);
+ }
+@@ -63,12 +65,15 @@ if (block) store_free(block);
+ static void *
+ function_store_get(PCRE2_SIZE size, void * tag)
+ {
++if (size > INT_MAX)
++ log_write(0, LOG_MAIN|LOG_PANIC_DIE, "excessive memory alloc request");
+ return store_get((int)size, GET_UNTAINTED); /* loses track of taint */
+ }
+
+ static void
+ function_store_nullfree(void * block, void * tag)
+ {
++/* We cannot free memory allocated using store_get() */
+ }
-+/* Free memory allocated by PCRE2 every so often, because a recent version
-+is now using 20kB for every match call */
-+
-+#define RESET_STORE_FILECNT 1000
- /*************************************************
- * Setup entry point *
+diff --git a/src/src/transports/appendfile.c b/src/src/transports/appendfile.c
+--- a/src/transports/appendfile.c
++++ b/src/transports/appendfile.c
@@ -661,13 +665,14 @@ Returns: the sum of the sizes of the stattable files
off_t
check_dir_size(const uschar * dirname, int * countptr, const pcre2_code * re)
{
--DIR *dir;
-+DIR * dir;
+ DIR *dir;
off_t sum = 0;
-int count = *countptr;
-+int count = *countptr, lcount = RESET_STORE_FILECNT;
++int count = *countptr, lcount = REGEX_LOOPCOUNT_STORE_RESET;
+rmark reset_point = store_mark();
if (!(dir = exim_opendir(dirname))) return 0;
--for (struct dirent *ent; ent = readdir(dir); )
-+for (struct dirent * ent; ent = readdir(dir); )
+ for (struct dirent *ent; ent = readdir(dir); )
{
uschar * path, * name = US ent->d_name;
struct stat statbuf;
@@ -41,7 +65,7 @@ index ec41ca035..91b353079 100644
+ if (--lcount == 0)
+ {
+ store_reset(reset_point); reset_point = store_mark();
-+ lcount = RESET_STORE_FILECNT;
++ lcount = REGEX_LOOPCOUNT_STORE_RESET;
+ }
/* If there's a regex, try to find the size using it */
@@ -54,3 +78,149 @@ index ec41ca035..91b353079 100644
*countptr = count;
return sum;
}
+diff --git a/src/src/macros.h b/src/src/macros.h
+--- a/src/macros.h
++++ b/src/macros.h
+@@ -1185,4 +1185,9 @@ typedef enum {
+ sw_mrc_tx_fail, /* transmit failed */
+ } sw_mrc_t;
+
++/* Recent versions of PCRE2 are allocating 20kB per match, rather than the previous 112 B.
++When doing en extended loop of matching, release store periodically. */
++
++#define REGEX_LOOPCOUNT_STORE_RESET 1000
++
+ /* End of macros.h */
+diff --git a/src/src/regex.c b/src/src/regex.c
+--- a/src/regex.c
++++ b/src/regex.c
+@@ -31,12 +31,11 @@ extern uschar *mime_current_boundary;
+
+
+ static pcre_list *
+-compile(const uschar * list, BOOL cacheable)
++compile(const uschar * list, BOOL cacheable, int * cntp)
+ {
+-int sep = 0;
++int sep = 0, cnt = 0;
+ uschar * regex_string;
+-pcre_list * re_list_head = NULL;
+-pcre_list * ri;
++pcre_list * re_list_head = NULL, * ri;
+
+ /* precompile our regexes */
+ while ((regex_string = string_nextinlist(&list, &sep, NULL, 0)))
+@@ -58,7 +57,9 @@ while ((regex_string = string_nextinlist(&list, &sep, NULL, 0)))
+ ri->pcre_text = regex_string;
+ ri->next = re_list_head;
+ re_list_head = ri;
++ cnt++;
+ }
++if (cntp) *cntp = cnt;
+ return re_list_head;
+ }
+
+@@ -112,7 +113,8 @@ FILE * mbox_file;
+ pcre_list * re_list_head;
+ uschar * linebuffer;
+ long f_pos = 0;
+-int ret = FAIL;
++int ret = FAIL, cnt, lcount = REGEX_LOOPCOUNT_STORE_RESET;
++rmark reset_point;
+
+ regex_vars_clear();
+
+@@ -136,26 +138,34 @@ else
+ mbox_file = mime_stream;
+ }
+
+-/* precompile our regexes */
+-if (!(re_list_head = compile(*listptr, cacheable)))
+- return FAIL; /* no regexes -> nothing to do */
+-
+-/* match each line against all regexes */
+-linebuffer = store_get(32767, GET_TAINTED);
+-while (fgets(CS linebuffer, 32767, mbox_file))
++reset_point = store_mark();
+ {
+- if ( mime_stream && mime_current_boundary /* check boundary */
+- && Ustrncmp(linebuffer, "--", 2) == 0
+- && Ustrncmp((linebuffer+2), mime_current_boundary,
+- Ustrlen(mime_current_boundary)) == 0)
+- break; /* found boundary */
+-
+- if ((ret = matcher(re_list_head, linebuffer, (int)Ustrlen(linebuffer))) == OK)
+- goto done;
++ /* precompile our regexes */
++ if ((re_list_head = compile(*listptr, cacheable, &cnt)))
++ {
++ /* match each line against all regexes */
++ linebuffer = store_get(32767, GET_TAINTED);
++ while (fgets(CS linebuffer, 32767, mbox_file))
++ {
++ if ( mime_stream && mime_current_boundary /* check boundary */
++ && Ustrncmp(linebuffer, "--", 2) == 0
++ && Ustrncmp((linebuffer+2), mime_current_boundary,
++ Ustrlen(mime_current_boundary)) == 0)
++ break; /* found boundary */
++
++ if ((ret = matcher(re_list_head, linebuffer, (int)Ustrlen(linebuffer))) == OK)
++ break;
++
++ if ((lcount -= cnt) <= 0)
++ {
++ store_reset(reset_point); reset_point = store_mark();
++ lcount = REGEX_LOOPCOUNT_STORE_RESET;
++ }
++ }
++ }
+ }
+-/* no matches ... */
++store_reset(reset_point);
+
+-done:
+ if (!mime_stream)
+ (void)fclose(mbox_file);
+ else
+@@ -180,14 +190,11 @@ pcre_list * re_list_head = NULL;
+ FILE * f;
+ uschar * mime_subject = NULL;
+ int mime_subject_len = 0;
+-int ret;
++int ret = FAIL;
++rmark reset_point;
+
+ regex_vars_clear();
+
+-/* precompile our regexes */
+-if (!(re_list_head = compile(*listptr, cacheable)))
+- return FAIL; /* no regexes -> nothing to do */
+-
+ /* check if the file is already decoded */
+ if (!mime_decoded_filename)
+ { /* no, decode it first */
+@@ -210,12 +217,20 @@ if (!(f = fopen(CS mime_decoded_filename, "rb")))
+ return DEFER;
+ }
+
+-/* get 32k memory, tainted */
+-mime_subject = store_get(32767, GET_TAINTED);
++reset_point = store_mark();
++ {
++ /* precompile our regexes */
++ if ((re_list_head = compile(*listptr, cacheable, NULL)))
++ {
++ /* get 32k memory, tainted */
++ mime_subject = store_get(32767, GET_TAINTED);
+
+-mime_subject_len = fread(mime_subject, 1, 32766, f);
++ mime_subject_len = fread(mime_subject, 1, 32766, f);
+
+-ret = matcher(re_list_head, mime_subject, mime_subject_len);
++ ret = matcher(re_list_head, mime_subject, mime_subject_len);
++ }
++ }
++store_reset(reset_point);
+ (void)fclose(f);
+ return ret;
+ }