summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 02:31:38 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 02:32:27 +0100
commit6634cdc743b4824d44c9d465d4084ba4c5eb0591 (patch)
tree972140beb8830ac059b95a19155191be3fd2aeb4
parentdev-lua/luacheck: update deps (diff)
downloadgentoo-6634cdc743b4824d44c9d465d4084ba4c5eb0591.tar.gz
gentoo-6634cdc743b4824d44c9d465d4084ba4c5eb0591.tar.bz2
gentoo-6634cdc743b4824d44c9d465d4084ba4c5eb0591.zip
dev-lua/luacheck: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luacheck/luacheck-0.20.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-lua/luacheck/luacheck-0.20.0.ebuild b/dev-lua/luacheck/luacheck-0.20.0.ebuild
deleted file mode 100644
index 070046152a0c..000000000000
--- a/dev-lua/luacheck/luacheck-0.20.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="A tool for linting and static analysis of Lua code"
-HOMEPAGE="https://github.com/mpeterv/luacheck"
-SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="doc luajit test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/luafilesystem[luajit=]
- !luajit? ( >=dev-lang/lua-5.1:= )
- luajit? ( dev-lang/luajit:2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? ( dev-lua/busted )"
-
-DOCS=( CHANGELOG.md README.md )
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- fi
-}
-
-src_test() {
- busted -o gtest || die
-}
-
-src_install() {
- local instdir
- instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
- insinto "${instdir#${EPREFIX}}"
- doins -r src/luacheck
-
- newbin bin/luacheck.lua luacheck
-
- use doc && HTML_DOCS+=( html/. )
-
- einstalldocs
-}