summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 16:17:08 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 16:17:08 +0100
commit665810256bb91588c6cee21b1d007db1685c68d4 (patch)
tree5aea135c30170f6aa35f93989ddd440fba0a3a2b
parentnet-mail/eps: Port to EAPI 7 (diff)
downloadgentoo-66581025.tar.gz
gentoo-66581025.tar.bz2
gentoo-66581025.zip
sci-libs/libccd: Disable static libs
Closes: https://bugs.gentoo.org/725422 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/libccd/libccd-2.1.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sci-libs/libccd/libccd-2.1.ebuild b/sci-libs/libccd/libccd-2.1.ebuild
index 8691045954d5..cdc23db29212 100644
--- a/sci-libs/libccd/libccd-2.1.ebuild
+++ b/sci-libs/libccd/libccd-2.1.ebuild
@@ -5,9 +5,9 @@ EAPI=7
inherit cmake
-if [ "${PV}" = "9999" ] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/danfis/libccd/${PN}.git"
+ EGIT_REPO_URI="https://github.com/danfis/libccd.git"
else
SRC_URI="https://github.com/danfis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
@@ -19,14 +19,10 @@ HOMEPAGE="http://libccd.danfis.cz/
LICENSE="BSD"
SLOT="0"
-IUSE="+double-precision doc +shared test"
+IUSE="+double-precision doc test"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
-"
+BDEPEND="doc? ( dev-python/sphinx )"
src_prepare() {
# upstream issue 72
@@ -40,11 +36,9 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc ON OFF)
- -DBUILD_SHARED_LIBS=$(usex shared ON OFF)
-DENABLE_DOUBLE_PRECISION=$(usex double-precision ON OFF)
)
- local CMAKE_BUILD_TYPE="Release"
cmake_src_configure
}