summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-12-23 17:07:22 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-01-10 09:11:33 +0200
commit66677539ec1ba23374f7d0ef4db71df1083d8a19 (patch)
treeb8b8822bbb243455561278e753ffd56c48dc6b90
parentwww-client/firefox-bin: sync wrapper path fix on prefix to esr (diff)
downloadgentoo-66677539ec1ba23374f7d0ef4db71df1083d8a19.tar.gz
gentoo-66677539ec1ba23374f7d0ef4db71df1083d8a19.tar.bz2
gentoo-66677539ec1ba23374f7d0ef4db71df1083d8a19.zip
games-engines/fheroes2: add 1.0.11
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.0.11.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index c2a4f889d18d..e83860fde1d3 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
DIST fheroes2-1.0.10.tar.gz 11810559 BLAKE2B 32e65a0763fc1b007152316e4453f818fb098f271e7038e18c7219221f3df64bb51e1b76086fa087d102dcd85bdf0e322bad6c5880fa86f235ebafbaf5d6155e SHA512 2510c5756b2a3c17b4eb560fb0d2bad900e9c268545f726a4f008a3153c9a6e9abb23c3586bb780cea65cfef3f3b05fe739cb717b30564d8cb886194effe2ec2
+DIST fheroes2-1.0.11.tar.gz 11881704 BLAKE2B cc594f519f3e9b83685365faafd30864fb899bf8509eb754c8d8d9a363b3cd23ba6fd10c8ff2df61fcc16ab964581ac801a4b4cb0afc7a566efa74d7aa39268e SHA512 eef909cf612a314d39a01a0c6b401a79cf1f418d2ddec16ad417a769242be67e9d5d14afcd4e1f908b4a86357ae1cb3cb6fca07d78d9d592958ba1db13288e34
diff --git a/games-engines/fheroes2/fheroes2-1.0.11.ebuild b/games-engines/fheroes2/fheroes2-1.0.11.ebuild
new file mode 100644
index 000000000000..c54e921e38d6
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.0.11.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ dev-lang/python
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}