summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-16 09:15:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-16 09:30:05 +0200
commit666c7efe6590a6dcbfc77e9f9dc8426a3b3073c3 (patch)
treeff25189c8d0ce73858b066e85fe7bb5cf2fa0f0f
parentdev-cpp/yaml-cpp: install cmake and .pc files to lib/ (diff)
downloadgentoo-666c7efe6590a6dcbfc77e9f9dc8426a3b3073c3.tar.gz
gentoo-666c7efe6590a6dcbfc77e9f9dc8426a3b3073c3.tar.bz2
gentoo-666c7efe6590a6dcbfc77e9f9dc8426a3b3073c3.zip
dev-python/zeep: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zeep/Manifest1
-rw-r--r--dev-python/zeep/zeep-4.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/zeep/Manifest b/dev-python/zeep/Manifest
index 1997ddc674c2..f94d3e4e9912 100644
--- a/dev-python/zeep/Manifest
+++ b/dev-python/zeep/Manifest
@@ -1,2 +1,3 @@
DIST zeep-3.4.0.tar.gz 163748 BLAKE2B 52709b22bf3dbe228630fcaca33dbfb1f9bb2fd6fab9a2f3ad1cfdf92f84aa2a5b1b71dbd5d41eca3bc12a9ac022d27191929533578441ff020e574fe2b95cd8 SHA512 31adea141ffaabb122a2127bcbba2742ed15d4cef91907c8db4aefd8550b2259502a4122825cbfa62559fd5babd3d0c6ce2bf82dd3b79cd9026d8ca008897349
DIST zeep-4.0.0.tar.gz 163646 BLAKE2B 84547f5ac5bfb42f6bfbe9879ae19466270e7699764a0f91b68d927d1776a040307ccc4f482dce93b765b8b3de191615d6a7b6a3fda38655c312c02a962fc954 SHA512 1ccc59d6ad1979f291cd89d0ac73d7bfc886501d7939c7e788b700454c571deffcc5a93c0e4fee7d6bbce4ad3cc2b309a95da57bcc4551ee5b37111e2fbc0acb
+DIST zeep-4.1.0.tar.gz 160333 BLAKE2B d29db92efe048ba854ff14cde062993c3f334cab6cfc122f6db9aa7a1a490c82f93a50ca5028a5f86e316d9ecf567ac40aef10f3e7d8db89376c7d8dea2a2e23 SHA512 acc54f99d21fe401e06418223591bcf8e7f8819e225f892beb0f6e2a1ee359a0da6f9d0aa4212899197c084af37cc56126879b93a22cdad2458e57674bf66ed5
diff --git a/dev-python/zeep/zeep-4.1.0.ebuild b/dev-python/zeep/zeep-4.1.0.ebuild
new file mode 100644
index 000000000000..751f99d24f08
--- /dev/null
+++ b/dev-python/zeep/zeep-4.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
+HOMEPAGE="http://docs.python-zeep.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="async"
+
+RDEPEND="
+ >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/aioresponses[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/python-xmlsec[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest