summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-01-02 21:00:28 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-01-02 21:00:28 +0000
commit667a1bfc583e75efefdbc007b69bd10d3989dc3f (patch)
treeb9db76d3ca207a757d04614d9d7ab8d0065f4653
parentgames-action/supertuxkart: Fix build with latest SDL2 (diff)
downloadgentoo-667a1bfc.tar.gz
gentoo-667a1bfc.tar.bz2
gentoo-667a1bfc.zip
net-firewall/firehol: Version bump to 3.1.7
Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--net-firewall/firehol/Manifest1
-rw-r--r--net-firewall/firehol/firehol-3.1.7.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-firewall/firehol/Manifest b/net-firewall/firehol/Manifest
index 7547639c83b2..e7ed5e2a55f8 100644
--- a/net-firewall/firehol/Manifest
+++ b/net-firewall/firehol/Manifest
@@ -1 +1,2 @@
DIST firehol-3.1.6.tar.xz 1484424 BLAKE2B aea45aa424b7b43ed0576916f52a785601a21489263c1b5c6abbf3b2b97db80bf2a2420ae8176cd55e335ab93c18a8209a47f467dba80a63cf2c319b3e3e27d8 SHA512 5ffa7e59d3f10a6c7d3f5b5ef9d93f1b2138063374a10cb0c1ac4e75578d6cf7755e154b51febf546563ba003f100af13f89bca3843b66a8d22b8fc2da3fadfe
+DIST firehol-3.1.7.tar.xz 1457932 BLAKE2B 9a861f2e9c900bce45d0dbd12f4546bc14eb4d74aea27a8d4cb0e5bfe8bea92d9bff3ccf008d46bd64212d689123273c99d0b0faaaadd34f0e1d85e22ee757c9 SHA512 b05cec806c2c8fc410bf9c7a30e3ad1d9f1c06fd2d501a7e5434010f6bb38722aac5b64de9b4285d2c71cacbf6b2f3c758685da5a70c05621df52879eb5148c2
diff --git a/net-firewall/firehol/firehol-3.1.7.ebuild b/net-firewall/firehol/firehol-3.1.7.ebuild
new file mode 100644
index 000000000000..3d7828d589f3
--- /dev/null
+++ b/net-firewall/firehol/firehol-3.1.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="https://firehol.org/ https://github.com/firehol/firehol"
+SRC_URI="https://github.com/firehol/firehol/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc ipv6 ipset"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2[-minimal,ipv6?]
+ sys-apps/kmod[tools]
+ net-misc/iputils[ipv6?]
+ net-misc/iprange
+ net-analyzer/traceroute
+ app-arch/gzip
+ ipset? (
+ net-firewall/ipset
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~IP_NF_FILTER \
+ ~IP_NF_IPTABLES \
+ ~IP_NF_MANGLE \
+ ~IP_NF_TARGET_MASQUERADE
+ ~IP_NF_TARGET_REDIRECT \
+ ~IP_NF_TARGET_REJECT \
+ ~NETFILTER_XT_CONNMARK \
+ ~NETFILTER_XT_MATCH_HELPER \
+ ~NETFILTER_XT_MATCH_LIMIT \
+ ~NETFILTER_XT_MATCH_OWNER \
+ ~NETFILTER_XT_MATCH_STATE \
+ ~NF_CONNTRACK \
+ ~NF_CONNTRACK_IPV4 \
+ ~NF_CONNTRACK_MARK \
+ ~NF_NAT \
+ ~NF_NAT_FTP \
+ ~NF_NAT_IRC \
+ "
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --disable-vnetbuild \
+ $(use_enable ipset update-ipsets) \
+ $(use_enable doc) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/firehol.confd firehol
+ newinitd "${FILESDIR}"/firehol.initd firehol
+ newconfd "${FILESDIR}"/fireqos.confd fireqos
+ newinitd "${FILESDIR}"/fireqos.initd fireqos
+}