summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2019-09-15 11:26:45 -0400
committerNick Sarnie <sarnex@gentoo.org>2019-09-15 11:26:45 -0400
commit667dd143d190d7f2aa209ae0b812727f3c34872a (patch)
treebba5ffbb70dd68cdd6a7aee15cb3389b68d75f4b
parentkde-plasma/plasma-nm: Fix missing headers with Frameworks 5.62 (diff)
downloadgentoo-667dd143.tar.gz
gentoo-667dd143.tar.bz2
gentoo-667dd143.zip
app-emulation/faudio: Sync with ::wine
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
-rw-r--r--app-emulation/faudio/Manifest1
-rw-r--r--app-emulation/faudio/faudio-19.03.ebuild95
-rw-r--r--app-emulation/faudio/faudio-9999.ebuild6
3 files changed, 3 insertions, 99 deletions
diff --git a/app-emulation/faudio/Manifest b/app-emulation/faudio/Manifest
index eb6ea01a4f4f..7fc3823eb2b7 100644
--- a/app-emulation/faudio/Manifest
+++ b/app-emulation/faudio/Manifest
@@ -1,2 +1 @@
-DIST FAudio-19.03.tar.gz 886621 BLAKE2B 0cf0b60766d48472c72dc2aa9bbdb9a99db27836f38eccacb4be4bd98cf387b6009998018438e46835a9b9616d426b8a2c9f3c200b377bce2dc9bc18e42b0d37 SHA512 94e3e4f3f023879ef821d657e5a73ac25aab55c7be6a0afe77d75cabe644c9da083ae3c6a240b71af542da53a3eb34804e6a3193a0e619f89fcc20ff7d6ef095
DIST FAudio-19.06.tar.gz 899089 BLAKE2B a59ad9613bcfa71e1fc8be1f2d389f56b8f96430c354b7c7148d1e1e084102b6d8559cd258f3ab6969a4ac93e55ea2397b18dc417857e9ee0f022ea0dae65c0e SHA512 ba3ee18b47d8d85dc39e777c420522349f9873cf1528dd6c266f7254fe27cdb5bb6ab5bcbeab870938b509bfd006590d2380908b7d1e3fd679d2a434ce82eca6
diff --git a/app-emulation/faudio/faudio-19.03.ebuild b/app-emulation/faudio/faudio-19.03.ebuild
deleted file mode 100644
index 295da5632494..000000000000
--- a/app-emulation/faudio/faudio-19.03.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# shellcheck disable=SC2034
-EAPI=7
-
-CMAKE_MAKEFILE_GENERATOR="emake"
-
-inherit cmake-multilib virtualx
-
-FAUDIO_PN="FAudio"
-FAUDIO_PV="${PV}"
-FAUDIO_P="${FAUDIO_PN}-${FAUDIO_PV}"
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/FNA-XNA/${FAUDIO_PN}.git"
-else
- SRC_URI="https://github.com/FNA-XNA/${FAUDIO_PN}/archive/${FAUDIO_PV}.tar.gz -> ${FAUDIO_P}.tar.gz"
- KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
- S="${WORKDIR}/${FAUDIO_P}"
-fi
-
-DESCRIPTION="FAudio - Accuracy-focused XAudio reimplementation for open platforms"
-HOMEPAGE="https://fna-xna.github.io/"
-LICENSE="ZLIB"
-SLOT="0"
-
-IUSE="+abi_x86_32 +abi_x86_64 debug ffmpeg xnasong test utils"
-REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
-
-COMMON_DEPEND="
- >=media-libs/libsdl2-2.0.9[sound,${MULTILIB_USEDEP}]
- ffmpeg? ( media-video/ffmpeg:=[${MULTILIB_USEDEP}] )
-"
-RDEPEND="${COMMON_DEPEND}
-"
-DEPEND="${COMMON_DEPEND}
-"
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DCMAKE_INSTALL_BINDIR=bin"
- "-DCMAKE_INSTALL_INCLUDEDIR=include/${FAUDIO_PN}"
- "-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
- "-DCMAKE_INSTALL_PREFIX=${EPREFIX%/}/usr"
- "-DCMAKE_BUILD_TYPE=$(usex debug Debug Release)"
- "-DFORCE_ENABLE_DEBUGCONFIGURATION=$(usex debug ON OFF)"
- "-DBUILD_TESTS=$(usex test ON OFF)"
- "-DBUILD_UTILS=$(usex utils ON OFF)"
- "-DFFMPEG=$(usex ffmpeg ON OFF)"
- "-DXNASONG=$(usex xnasong ON OFF)"
- )
- if use ffmpeg; then
- mycmakeargs+=( "-DFFmpeg_LIBRARY_DIRS=${PREFIX%/}/usr/$(get_libdir)" )
- fi
- cmake-utils_src_configure
-}
-
-src_configure() {
- cmake-multilib_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_make
- emake -C "${BUILD_DIR}" all
-}
-
-multilib_src_install() {
- # FIXME: do we want to install the FAudio tools?
- cmake-utils_src_install
-
- sed -e "s/%LIB%/$(get_libdir)/g" "${FILESDIR}/faudio.pc" \
- > "${T}/faudio.pc" \
- || die "sed failed"
- insinto "/usr/$(get_libdir)/pkgconfig"
- doins "${T}/faudio.pc"
-
- if use test; then
- mkdir -p "${T}/$(get_libdir)"
- cp "${BUILD_DIR}/faudio_tests" "${T}/$(get_libdir)/" || die "cp failed"
- fi
-}
-
-faudio_test() {
- XDG_RUNTIME_DIR="/run/user/0" virtx "${T}/$(get_libdir)/faudio_tests"
-}
-
-pkg_postinst() {
- use test || return
-
- # FIXME: FAudio tests are broken and also don't appear to work
- # in the Portage sandbox.
- multilib_foreach_abi faudio_test
-}
diff --git a/app-emulation/faudio/faudio-9999.ebuild b/app-emulation/faudio/faudio-9999.ebuild
index 295da5632494..a8490f1cf230 100644
--- a/app-emulation/faudio/faudio-9999.ebuild
+++ b/app-emulation/faudio/faudio-9999.ebuild
@@ -52,7 +52,7 @@ multilib_src_configure() {
"-DXNASONG=$(usex xnasong ON OFF)"
)
if use ffmpeg; then
- mycmakeargs+=( "-DFFmpeg_LIBRARY_DIRS=${PREFIX%/}/usr/$(get_libdir)" )
+ mycmakeargs+=( "-DFFmpeg_LIBRARY_DIRS=${EPREFIX%/}/usr/$(get_libdir)" )
fi
cmake-utils_src_configure
}
@@ -70,8 +70,8 @@ multilib_src_install() {
# FIXME: do we want to install the FAudio tools?
cmake-utils_src_install
- sed -e "s/%LIB%/$(get_libdir)/g" "${FILESDIR}/faudio.pc" \
- > "${T}/faudio.pc" \
+ sed -e "s@%LIB%@$(get_libdir)@g" -e "s@%PREFIX%@${EPREFIX}/usr@g" \
+ "${FILESDIR}/faudio.pc" > "${T}/faudio.pc" \
|| die "sed failed"
insinto "/usr/$(get_libdir)/pkgconfig"
doins "${T}/faudio.pc"