summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-01-07 18:14:47 +0100
committerAnthony G. Basile <blueness@gentoo.org>2017-01-07 17:27:51 -0500
commit668f2bb06e8acb02d92e1a2f7eeea0b392888b90 (patch)
tree98ecfa7e86d651c9f2ffc8ba921ea4a26e4efcdd
parentnet-proxy/obfsproxy: remove unused patches/init files (diff)
downloadgentoo-668f2bb06e8acb02d92e1a2f7eeea0b392888b90.tar.gz
gentoo-668f2bb06e8acb02d92e1a2f7eeea0b392888b90.tar.bz2
gentoo-668f2bb06e8acb02d92e1a2f7eeea0b392888b90.zip
net-proxy/torsocks: remove unused patches
-rw-r--r--net-proxy/torsocks/files/fix-docdir.patch24
-rw-r--r--net-proxy/torsocks/files/suppress-warning-msgs.patch15
-rw-r--r--net-proxy/torsocks/files/torsocks-2.1.0-musl.patch121
3 files changed, 0 insertions, 160 deletions
diff --git a/net-proxy/torsocks/files/fix-docdir.patch b/net-proxy/torsocks/files/fix-docdir.patch
deleted file mode 100644
index 899c15b16721..000000000000
--- a/net-proxy/torsocks/files/fix-docdir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur torsocks-1.2.orig/doc/Makefile.am torsocks-1.2/doc/Makefile.am
---- torsocks-1.2.orig/doc/Makefile.am 2011-10-26 14:30:26.000000000 -0400
-+++ torsocks-1.2/doc/Makefile.am 2011-12-26 20:05:40.000000000 -0500
-@@ -7,8 +7,6 @@
- # Install man pages
- dist_man_MANS = torsocks.1 torsocks.8 usewithtor.1 torsocks.conf.5
-
--dist_data_DATA = socks/SOCKS5 socks/SOCKS4.protocol socks/socks-extensions.txt \
-- patches/compilewarnings.patch patches/conffile.patch patches/getaddrbyhost.patch \
-- patches/getpeername.patch patches/infiniteloop.patch patches/localaddresses.patch \
-- patches/README patches/README.TORDNS patches/tordns.patch notes/DEBUG
-+dist_doc_DATA = socks/SOCKS5 socks/SOCKS4.protocol socks/socks-extensions.txt \
-+ notes/DEBUG
-
-diff -Naur torsocks-1.2.orig/test/Makefile.am torsocks-1.2/test/Makefile.am
---- torsocks-1.2.orig/test/Makefile.am 2011-10-26 14:21:57.000000000 -0400
-+++ torsocks-1.2/test/Makefile.am 2011-12-26 20:04:34.000000000 -0500
-@@ -4,4 +4,4 @@
- test_torsocks_LDFLAGS= $(TESTLDFLAGS)
- CLEANFILES= test_torsocks
-
--dist_data_DATA = run_tests.sh expectedresults.txt
-\ No newline at end of file
-+dist_doc_DATA = run_tests.sh expectedresults.txt
diff --git a/net-proxy/torsocks/files/suppress-warning-msgs.patch b/net-proxy/torsocks/files/suppress-warning-msgs.patch
deleted file mode 100644
index 7470b9fa7f4b..000000000000
--- a/net-proxy/torsocks/files/suppress-warning-msgs.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- torsocks-1.2.orig/src/torsocks.c 2011-10-25 17:49:50.000000000 -0400
-+++ torsocks-1.2/src/torsocks.c 2012-02-21 11:09:20.000000000 -0500
-@@ -124,9 +124,9 @@
- #define LOAD_ERROR(s,l) { \
- const char *error; \
- error = dlerror(); \
-- show_msg(l, "The symbol %s() was not found in any shared " \
-- "library. The error reported was: %s!\n", s, \
-- (error)?error:"not found"); \
-+ if (error) \
-+ show_msg(l, "The symbol %s() was not found in any shared " \
-+ "library. The error reported was: %s!\n", s, error); \
- dlerror(); \
- }
- pthread_mutex_lock(&torsocks_init_mutex);
diff --git a/net-proxy/torsocks/files/torsocks-2.1.0-musl.patch b/net-proxy/torsocks/files/torsocks-2.1.0-musl.patch
deleted file mode 100644
index c11cf6915506..000000000000
--- a/net-proxy/torsocks/files/torsocks-2.1.0-musl.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-From 3e793e9eac05ad926cc016da5129e95986d105f2 Mon Sep 17 00:00:00 2001
-From: David Goulet <dgoulet@ev0ke.net>
-Date: Mon, 13 Jun 2016 14:39:53 -0400
-Subject: [PATCH] Add support for musl-libc
-
-Musl library does not have a specific define so use __linux__ instead.
-
-Signed-off-by: David Goulet <dgoulet@ev0ke.net>
----
- src/common/compat.c | 5 +++--
- src/common/compat.h | 5 +++--
- src/common/ref.h | 5 +++--
- src/lib/torsocks.h | 9 +++++----
- 4 files changed, 14 insertions(+), 10 deletions(-)
-
-diff --git a/src/common/compat.c b/src/common/compat.c
-index a861b3d..323f2ed 100644
---- a/src/common/compat.c
-+++ b/src/common/compat.c
-@@ -19,7 +19,8 @@
-
- #include "compat.h"
-
--#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
-+#if (defined(__linux__) || defined(__GLIBC__) || defined(__FreeBSD__) || \
-+ defined(__darwin__) || defined(__NetBSD__))
-
- /*
- * Initialize a pthread mutex. This never fails.
-@@ -96,4 +97,4 @@ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void))
- tsocks_mutex_unlock(&o->mutex);
- }
-
--#endif /* __GLIBC__, __darwin__, __FreeBSD__, __NetBSD__ */
-+#endif /* __linux__, __GLIBC__, __darwin__, __FreeBSD__, __NetBSD__ */
-diff --git a/src/common/compat.h b/src/common/compat.h
-index ce47129..6c8ce32 100644
---- a/src/common/compat.h
-+++ b/src/common/compat.h
-@@ -22,7 +22,8 @@
- #define __darwin__ 1
- #endif
-
--#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
-+#if (defined(__linux__) || defined(__GLIBC__) || defined(__FreeBSD__) || \
-+ defined(__darwin__) || defined(__NetBSD__))
-
- #define RTLD_NEXT ((void *) -1)
-
-@@ -55,7 +56,7 @@ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void));
-
- #else
- #error "OS not supported."
--#endif /* __GLIBC__, __darwin__, __FreeBSD__, __NetBSD__ */
-+#endif /* __linux__, __GLIBC__, __darwin__, __FreeBSD__, __NetBSD__ */
-
- #if defined(__linux__)
- #include <unistd.h>
-diff --git a/src/common/ref.h b/src/common/ref.h
-index 88aec2e..d9b9df8 100644
---- a/src/common/ref.h
-+++ b/src/common/ref.h
-@@ -26,7 +26,8 @@ struct ref {
- long count;
- };
-
--#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
-+#if (defined(__linux__) || defined(__GLIBC__) || defined(__FreeBSD__) || \
-+ defined(__darwin__) || defined(__NetBSD__))
-
- /*
- * Get a reference by incrementing the refcount.
-@@ -57,6 +58,6 @@ static inline void ref_put(struct ref *r,
-
- #else
- #error "OS not supported"
--#endif /* __GLIBC__, __FreeBSD__, __darwin__ */
-+#endif /* __linux__, __GLIBC__, __FreeBSD__, __darwin__, __NetBSD__ */
-
- #endif /* TORSOCKS_REF_H */
-diff --git a/src/lib/torsocks.h b/src/lib/torsocks.h
-index 076f3a5..0eeef2a 100644
---- a/src/lib/torsocks.h
-+++ b/src/lib/torsocks.h
-@@ -33,7 +33,8 @@
- #define TSOCKS_DECL(name, type, sig) \
- extern type tsocks_##name(sig);
-
--#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
-+#if (defined(__linux__) || defined(__GLIBC__) || defined(__FreeBSD__) || \
-+ defined(__darwin__) || defined(__NetBSD__))
-
- /* connect(2) */
- #include <sys/types.h>
-@@ -207,7 +208,7 @@ struct hostent **result, int *h_errnop
-
- #else
- #error "OS not supported."
--#endif /* __GLIBC__ , __FreeBSD__, __darwin__, __NetBSD__ */
-+#endif /* __linux__, __GLIBC__ , __FreeBSD__, __darwin__, __NetBSD__ */
-
- #if (defined(__linux__))
-
-@@ -241,7 +242,7 @@ struct hostent **result, int *h_errnop
-
- #endif /* __FreeBSD__, __darwin__, __NetBSD__ */
-
--#if defined(__GLIBC__) && defined(__FreeBSD_kernel__)
-+#if (defined(__linux__) || defined(__GLIBC__)) && defined(__FreeBSD_kernel__)
-
- /* syscall(2) */
- #define LIBC_SYSCALL_NAME syscall
-@@ -250,7 +251,7 @@ struct hostent **result, int *h_errnop
- #define LIBC_SYSCALL_SIG long int number, ...
- #define LIBC_SYSCALL_ARGS number
-
--#endif /* __GLIBC__ && __FreeBSD_kernel__ */
-+#endif /* (__linux__ || __GLIBC__) && __FreeBSD_kernel__ */
-
- /* __syscall(2) */
- #if defined(__FreeBSD__)