summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-16 07:41:22 +0000
committerSam James <sam@gentoo.org>2023-12-16 07:44:24 +0000
commit668fdf70fb0c90001d611e5399d32b83dd03b976 (patch)
treed23dcd076f0782d02dbb04a9a93068815c2f6f88
parentapp-shells/zsh: fix modern C configure issue, fix relro plugin issue (diff)
downloadgentoo-668fdf70.tar.gz
gentoo-668fdf70.tar.bz2
gentoo-668fdf70.zip
dev-libs/boehm-gc: drop 8.0.6, 8.0.8, 8.2.2-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/boehm-gc/Manifest3
-rw-r--r--dev-libs/boehm-gc/boehm-gc-8.0.6.ebuild53
-rw-r--r--dev-libs/boehm-gc/boehm-gc-8.0.8.ebuild54
-rw-r--r--dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild63
-rw-r--r--dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch43
5 files changed, 0 insertions, 216 deletions
diff --git a/dev-libs/boehm-gc/Manifest b/dev-libs/boehm-gc/Manifest
index 51568a81cabe..1b8f14d97c50 100644
--- a/dev-libs/boehm-gc/Manifest
+++ b/dev-libs/boehm-gc/Manifest
@@ -1,4 +1 @@
-DIST gc-8.0.6.tar.gz 1168660 BLAKE2B c23cb10db54db0e8b16c429e039791086dfec4216ad65fabf072bc0f05df66364d019fccf945bffc32ce12868edfbaf6d9482acb2949d1e233bd89925ab55ebd SHA512 2ea25003d585118e3ac0e12be9240e8195db511c6e94949f20453dc3cb771380bd5b956c04243b2a8ce31508587aa32de4f0f10a813577e6dbe8367688b7614e
-DIST gc-8.0.8.tar.gz 1173619 BLAKE2B 5caa3839390f0a727d7b6fafc13094507326f42c57766ef3f80fb59d64ebbe00e780990735bdefcf26d160a1ae8d44c0d9658310314877b11a91e064a875483a SHA512 c09da03883170b91e7d4904484266948472018a42092f7df42798507666d693327895ef8348f7cb0007f7e4948fbd0476e4021f5a203838157ce46ef3a401f7b
-DIST gc-8.2.2.tar.gz 1200115 BLAKE2B 9f0306f24189687f0e9e58cd942d67e94d009bd4c9a88556edaae756f902ce71f7eed2ee66a9a9b2e8e40c54653796f494104b395828282b83ee6a89a5542378 SHA512 4a7b26789ce22ab72bfaadf3029362c5fe26737df1e856e43db7d9b24ee8acf625e35d596bb3f698f91d6a5ddfb6c45a952a1dbd18d47359569696a544c9c248
DIST gc-8.2.4.tar.gz 1210929 BLAKE2B 48f058b3f6f9f708d4335a7a0b077aab4ea5df32be73038bb8c20c12483d7ec8798b16db85afed5aa270f0f818de08abf9407036f662c757f361a929f99d951f SHA512 27d014378000f25fb2f5598904be85604822d5ed4553f8b3d1c279122300d3958b4432ec08f951cfd842d92121ea8a030dda34bf2475ec53d4fded551fdd3a98
diff --git a/dev-libs/boehm-gc/boehm-gc-8.0.6.ebuild b/dev-libs/boehm-gc/boehm-gc-8.0.6.ebuild
deleted file mode 100644
index 4cc7f559e4bf..000000000000
--- a/dev-libs/boehm-gc/boehm-gc-8.0.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-minimal libtool
-
-MY_P="gc-${PV}"
-
-DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
-HOMEPAGE="https://www.hboehm.info/gc/ https://github.com/ivmai/bdwgc/"
-SRC_URI="https://github.com/ivmai/bdwgc/releases/download/v${PV}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="boehm-gc"
-# SONAME: libgc.so.1 libgccpp.so.1
-# We've been using subslot 0 for these instead of "1.1".
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="cxx +large static-libs +threads"
-
-RDEPEND=">=dev-libs/libatomic_ops-7.4[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
- elibtoolize #594754
-}
-
-multilib_src_configure() {
- local config=(
- --disable-docs
- --with-libatomic-ops
- $(use_enable cxx cplusplus)
- $(use_enable static-libs static)
- $(use threads || echo --disable-threads)
- $(use_enable large large-config)
- )
-
- ECONF_SOURCE=${S} econf "${config[@]}"
-}
-
-multilib_src_install_all() {
- local HTML_DOCS=( doc/*.md )
- einstalldocs
- dodoc doc/README{.environment,.linux,.macros}
-
- # package provides .pc files
- find "${ED}" -name '*.la' -delete || die
-
- newman doc/gc.man GC_malloc.1
-}
diff --git a/dev-libs/boehm-gc/boehm-gc-8.0.8.ebuild b/dev-libs/boehm-gc/boehm-gc-8.0.8.ebuild
deleted file mode 100644
index 479709474e41..000000000000
--- a/dev-libs/boehm-gc/boehm-gc-8.0.8.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-minimal libtool
-
-MY_P="gc-${PV}"
-DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
-HOMEPAGE="https://www.hboehm.info/gc/ https://github.com/ivmai/bdwgc/"
-SRC_URI="https://github.com/ivmai/bdwgc/releases/download/v${PV}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="boehm-gc"
-# SONAME: libgc.so.1 libgccpp.so.1
-# We've been using subslot 0 for these instead of "1.1".
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="cxx +large static-libs +threads"
-
-RDEPEND=">=dev-libs/libatomic_ops-7.4[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- # bug #594754
- elibtoolize
-}
-
-multilib_src_configure() {
- local config=(
- --disable-docs
- --with-libatomic-ops
- $(use_enable cxx cplusplus)
- $(use_enable static-libs static)
- $(use threads || echo --disable-threads)
- $(use_enable large large-config)
- )
-
- ECONF_SOURCE="${S}" econf "${config[@]}"
-}
-
-multilib_src_install_all() {
- local HTML_DOCS=( doc/*.md )
- einstalldocs
- dodoc doc/README{.environment,.linux,.macros}
-
- # Package provides .pc files
- find "${ED}" -name '*.la' -delete || die
-
- newman doc/gc.man GC_malloc.1
-}
diff --git a/dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild
deleted file mode 100644
index c4048ab70e90..000000000000
--- a/dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# autotools for Clang 15 configure patch
-inherit autotools multilib-minimal #libtool
-
-MY_P="gc-${PV}"
-
-DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
-HOMEPAGE="https://www.hboehm.info/gc/ https://github.com/ivmai/bdwgc/"
-SRC_URI="https://github.com/ivmai/bdwgc/releases/download/v${PV}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="boehm-gc"
-# SONAME: libgc.so.1 libgccpp.so.1
-# We've been using subslot 0 for these instead of "1.1".
-SLOT="0"
-# Upstream marked this version as "Pre-release"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="cxx +large static-libs +threads"
-
-RDEPEND=">=dev-libs/libatomic_ops-7.4[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-8.2.2-clang-15-configure.patch
-)
-
-src_prepare() {
- default
-
- # bug #594754
- #elibtoolize
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local config=(
- --disable-docs
- --with-libatomic-ops
- $(use_enable cxx cplusplus)
- $(use_enable static-libs static)
- $(use threads || echo --disable-threads)
- $(use_enable large large-config)
- )
-
- ECONF_SOURCE="${S}" econf "${config[@]}"
-}
-
-multilib_src_install_all() {
- local HTML_DOCS=( doc/*.md )
- einstalldocs
- dodoc doc/README{.environment,.linux,.macros}
-
- # Package provides .pc files
- find "${ED}" -name '*.la' -delete || die
-
- newman doc/gc.man GC_malloc.1
-}
diff --git a/dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch b/dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch
deleted file mode 100644
index 87045eaa912f..000000000000
--- a/dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-https://github.com/ivmai/bdwgc/pull/474
-
-From b3428e52cb9af18d6c85d0027b9c86e9b44e2e4f Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Tue, 13 Sep 2022 19:37:59 +0100
-Subject: [PATCH] Fix configure with Clang 15 (implicit function declarations)
-
-Clang 15 makes implicit function declarations an error by default
-which leads to configure falsely thinking `pthread_setname_np` is
-not present:
-```
-checking for pthread_setname_np... no
-```
-
-This fixes that issue and the following errors:
-```
-error: call to undeclared function 'pthread_setname_np'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
-error: call to undeclared function 'pthread_setname_np'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
-```
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/configure.ac
-+++ b/configure.ac
-@@ -834,12 +834,16 @@ AS_IF([test "$THREADS" = posix],
- [AC_MSG_CHECKING(for pthread_setname_np)
- old_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $CFLAGS_EXTRA -Werror"
-- AC_TRY_COMPILE([#include <pthread.h>],
-+ AC_TRY_COMPILE([
-+#define _GNU_SOURCE 1
-+#include <pthread.h>],
- [pthread_setname_np("thread-name")],
- [AC_MSG_RESULT([yes (w/o tid)])
- AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITHOUT_TID], [1],
- [Define to use 'pthread_setname_np(const char*)' function.])],
-- [AC_TRY_COMPILE([#include <pthread.h>],
-+ [AC_TRY_COMPILE([
-+#define _GNU_SOURCE 1
-+#include <pthread.h>],
- [pthread_setname_np(pthread_self(), "thread-name-%u", 0)],
- [AC_MSG_RESULT([yes (with tid and arg)])
- AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITH_TID_AND_ARG], [1],
-