summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-03-09 17:30:39 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-09 18:20:33 +0200
commit6690c260eb049a1225b0707cc30a586b30776b77 (patch)
tree558c2061e185e3ccc789cfa79231f1a83dd7d421
parentdev-python/sqlglot: add 22.3.1 (diff)
downloadgentoo-6690c260eb049a1225b0707cc30a586b30776b77.tar.gz
gentoo-6690c260eb049a1225b0707cc30a586b30776b77.tar.bz2
gentoo-6690c260eb049a1225b0707cc30a586b30776b77.zip
dev-python/noseofyeti: add 2.4.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/noseofyeti/Manifest1
-rw-r--r--dev-python/noseofyeti/noseofyeti-2.4.8.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/noseofyeti/Manifest b/dev-python/noseofyeti/Manifest
index ea164d82d5a2..096745ce2fa7 100644
--- a/dev-python/noseofyeti/Manifest
+++ b/dev-python/noseofyeti/Manifest
@@ -1 +1,2 @@
DIST noseofyeti-2.4.7.tar.gz 35637 BLAKE2B 44524d46ae7a278029ec6a321e4b44085ac9082d0a2fb44726777ff40a575ec100baf5554da29411fef992da0d435cd6c14ff15364ed92d74c98efe32eda56bd SHA512 c6254c54541f9cec2fbe25416013d8f76d0c32c8b403b6ba79b38522460ffbefd29565fc640e8ed54c30efe641755e125a5884a97de4f86a2bd3555bf8f6b294
+DIST noseofyeti-2.4.8.tar.gz 35866 BLAKE2B 6f11c7eb1db03ed27a8838e8b774cea97189609d8b7204facc3784968119878944b28231ab1f0d42f3eaa2679fee15df465e9069d1b4473ce8e5cd1749ace0b5 SHA512 78c685da52e993dc28c758dbf4395bbd544d0f4e9993f17a7f1ce267d03ba1c4a5e43cfcb2b2110e6fc21dcc60c6fcdd2bafb3f2d8ab2535a9429430ffc9308a
diff --git a/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild b/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild
new file mode 100644
index 000000000000..97c4ffc90e9f
--- /dev/null
+++ b/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A custom python codec that provides an RSpec style dsl for python"
+HOMEPAGE="
+ https://github.com/delfick/nose-of-yeti/
+ https://pypi.org/project/noseOfYeti/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires alt-pytest-asyncio
+ tests/test_using_pytest.py::TestPyTest::test_it_collects_tests_correctly
+)