summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-06-19 19:22:42 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-06-19 19:23:16 +0200
commit66959fabf450c970ec63195b9f882dc3d8f0a7d9 (patch)
treea953b1e5ed048323341e0d31f03b25e183b4c34d
parentdev-python/humanize: add 4.2.0 (diff)
downloadgentoo-66959fab.tar.gz
gentoo-66959fab.tar.bz2
gentoo-66959fab.zip
games-strategy/wesnoth: Bump to version 1.16.3
Closes: https://bugs.gentoo.org/835587 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.3.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index fd1ae547afc1..afa25880c8f0 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,2 +1,3 @@
DIST wesnoth-1.16.0.tar.gz 515780018 BLAKE2B 1a9d6aa9b294b9919d3b51528928f43d786f30fda739f0af2e62ebbb210b8f071945fe6130c00e2055d3726ae7eabf63b57fd2f1d5d8981a4cd0feedbfbffbfb SHA512 6d999a99e140916ef2070c524898ef69c7b45b3240f208aa380e81a1d1822a02c05a7fc9c5049a05a230e5126d8ff8723e16b6a62ba532b81c031f78ad8c85fe
DIST wesnoth-1.16.2.tar.gz 517313669 BLAKE2B b1b9a2795a7a298edd1d952547db518a31f217f983aaf39cdde7a14773f2538485c980205e9242d4a1c8f933011a09a7e858de128c7d17c16c552e34b2a59bf3 SHA512 19cb4c64d9cce780ffbb54e357bf88c3cf2eedc835fab7162bd9caa62485a60ab2a1ba68ab0c4b98dc05bab4fb22889f4a8237b9542baa5478fbda08034d9f66
+DIST wesnoth-1.16.3.tar.gz 518049863 BLAKE2B e862de2e6f71a1dfe11b0cb6343ea1da78c0eb035893d7bd16ca86586b689b21f39b5266ba86476829c1c9005f7abc37058c2f0ac8ea1ae2970d609880e0da20 SHA512 7f37a1a16ed51ffa935a457553b1a3890398b928bb5893720b746080b37a121a86e21ae402bdddfe30572adccf71a985bf1e3223a0eb443bf7a696ee213d9bf0
diff --git a/games-strategy/wesnoth/wesnoth-1.16.3.ebuild b/games-strategy/wesnoth/wesnoth-1.16.3.ebuild
new file mode 100644
index 000000000000..17cdd9a055f7
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.16.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ dev-libs/boost:=[bzip2,context,icu,nls,threads(+)]
+ >=media-libs/libsdl2-2.0.4:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+
+ if use dedicated || use server ; then
+ mycmakeargs=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server ; then
+ rmdir "${ED}"/run{/wesnothd,} || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}