summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-27 16:27:14 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-27 16:40:21 -0400
commit66a14ebfa4c715dabd2448f08510a2cb030dbfa7 (patch)
treefbe9d5ff74dc5b41671f7141e4e665d36b9ddb08
parentgames-puzzle/gnome2048: Version bump to 3.38.2 (diff)
downloadgentoo-66a14ebf.tar.gz
gentoo-66a14ebf.tar.bz2
gentoo-66a14ebf.zip
games-puzzle/lightsoff: Version bump to 40.0.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--games-puzzle/lightsoff/Manifest1
-rw-r--r--games-puzzle/lightsoff/lightsoff-40.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/lightsoff/Manifest b/games-puzzle/lightsoff/Manifest
index e252d05a1ae1..742dbd050a1d 100644
--- a/games-puzzle/lightsoff/Manifest
+++ b/games-puzzle/lightsoff/Manifest
@@ -1 +1,2 @@
DIST lightsoff-3.36.0.tar.xz 497756 BLAKE2B 1765f848608a40feda87e7e950675febcccb307639b6aeec3f12001516f80766a815e8989ba9c18813a397759efedd251921d988091be2bdd7c8c887a296bfe5 SHA512 9d026432bf059fb72aa8aab7b52c22e81acca12c8ba6a26350970a22a760a5d113958288196acc38d6ecba1096155323ecef86406e94d35e9ed82f26f9e30eae
+DIST lightsoff-40.0.1.tar.xz 562340 BLAKE2B c80aa328e56a1cb8da723c187c6a223d0bf93353f36ed651b10c38ac129c6d62970dcf72308cbbf4fd0f911113b5c53ed490824b488bdc92e84c7bd9e9ae1015 SHA512 ac1f812c3297a42f1e5aa8b8cdda2884b5c2aea2ea0190047ba5a0f47254b191d2105d7d1b548f0233fdee1b0e6033a97265a1cb28503daf403ee4e2c53a1aca
diff --git a/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild b/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild
new file mode 100644
index 000000000000..47b3e2b99329
--- /dev/null
+++ b/games-puzzle/lightsoff/lightsoff-40.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Turn off all the lights"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lightsoff"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}