summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-06-19 19:28:49 +0200
committerPacho Ramos <pacho@gentoo.org>2023-06-19 19:38:34 +0200
commit66e3b3f789a52bf8db20ea75211533cecd132749 (patch)
tree35175dbf23d534d189298ffdf7346d54fc5cce84
parentdev-python/graph-tool: sync live ebuild (diff)
downloadgentoo-66e3b3f789a52bf8db20ea75211533cecd132749.tar.gz
gentoo-66e3b3f789a52bf8db20ea75211533cecd132749.tar.bz2
gentoo-66e3b3f789a52bf8db20ea75211533cecd132749.zip
media-sound/pithos: It seems compatible with hicolor-icon-theme
Closes: https://bugs.gentoo.org/892387 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-sound/pithos/pithos-1.6.1-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/pithos/pithos-1.6.1-r1.ebuild b/media-sound/pithos/pithos-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..d6115fadc61b
--- /dev/null
+++ b/media-sound/pithos/pithos-1.6.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit xdg meson gnome2-utils virtualx python-r1
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="https://pithos.github.io/"
+SRC_URI="https://github.com/pithos/pithos/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="appindicator +keybinder libnotify test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ app-crypt/libsecret[introspection]
+ dev-libs/appstream-glib[introspection]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/hicolor-icon-theme
+ appindicator? ( dev-libs/libdbusmenu[gtk3,introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )
+ libnotify? ( x11-libs/libnotify[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-libs/glib:2
+ dev-util/desktop-file-utils
+ )
+"
+
+src_configure() {
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ virtx python_foreach_impl meson_src_test
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}