summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-28 05:25:21 +0100
committerSam James <sam@gentoo.org>2022-05-28 05:25:44 +0100
commit66e451177a6d28cfa24a3fdcdeaac7e8196c19fc (patch)
tree6961de07e9f4bf87ba014794018a2e4f4a42a1a3
parentprofiles/arch/loong: undo the global perl-5.36 mask for wider testing (diff)
downloadgentoo-66e451177a6d28cfa24a3fdcdeaac7e8196c19fc.tar.gz
gentoo-66e451177a6d28cfa24a3fdcdeaac7e8196c19fc.tar.bz2
gentoo-66e451177a6d28cfa24a3fdcdeaac7e8196c19fc.zip
net-print/cups: add 2.4.2
While at it, cleanup a bunch of obsolete seds and such. Checked upstream changes to ensure they really are obsolete. Bug: https://bugs.gentoo.org/847625 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-print/cups/Manifest1
-rw-r--r--net-print/cups/cups-2.4.2.ebuild302
-rw-r--r--net-print/cups/cups-9999.ebuild57
-rw-r--r--net-print/cups/files/cups-2.4.2-no-fortify-override.patch18
4 files changed, 346 insertions, 32 deletions
diff --git a/net-print/cups/Manifest b/net-print/cups/Manifest
index 0dc21ac8d17e..70e6ff821ff8 100644
--- a/net-print/cups/Manifest
+++ b/net-print/cups/Manifest
@@ -1,2 +1,3 @@
DIST cups-2.3.3op2-source.tar.gz 7993205 BLAKE2B 8c115b91ec185a4820578561aaf681238280b22b5c68b68c484ffbd0fa3c4ec1beb4d426e3f0e33192e32bce78aa8b7f50ed6799732a467fa9e75c34787057ee SHA512 db27dd6fb616bd7ad895b2bdf4ea7b010501358a50dc8f2e7e29558d1cfc088a572b1b35ac512654d3ed410c84df87dc34ca636533a4499117253915d4763117
DIST cups-2.4.1-source.tar.gz 8113914 BLAKE2B 690d9d92f9bc84c2bb360699191cd67e1489ffc3ab219376dfc1a8795379950c95bf58c2033a0dbd2918262c5d104e21e31c4585cb35d229b0fac6cf4967bfd7 SHA512 74e83728fcc3baf709176442b26711250fd4d4ede1e81e35b02a5607711067e28cd5a05d5bc3337953f6b2236c5a429b13f3a7f1218a08a2d3c30a8c9b0d96fd
+DIST cups-2.4.2-source.tar.gz 8128785 BLAKE2B 97053feb502d4fdc28810b806000b6c84a6795d5adcec0789e73e5477d5802d46a99381366d16219f627166df088f6decde5c144bd0c38b5745815dc1e426bc5 SHA512 07474643bffe11c79b3226b70d28f1bb803dc19daa10711938cea303feacdcce3945ba8ff0334d94fdd5922ea7d6bf37a28c1ea62cce8ce946c2f90a0faf002f
diff --git a/net-print/cups/cups-2.4.2.ebuild b/net-print/cups/cups-2.4.2.ebuild
new file mode 100644
index 000000000000..11e9e6c732a6
--- /dev/null
+++ b/net-print/cups/cups-2.4.2.ebuild
@@ -0,0 +1,302 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info xdg multilib-minimal optfeature pam toolchain-funcs
+
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_PV="${MY_PV/_p/op}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ #EGIT_REPO_URI="https://github.com/apple/cups.git"
+ EGIT_REPO_URI="https://github.com/OpenPrinting/cups.git"
+ [[ ${PV} != 9999 ]] && EGIT_BRANCH=branch-${PV/.9999}
+else
+ #SRC_URI="https://github.com/apple/cups/releases/download/v${MY_PV}/${MY_P}-source.tar.gz"
+ SRC_URI="https://github.com/OpenPrinting/cups/releases/download/v${MY_PV}/cups-${MY_PV}-source.tar.gz"
+ if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ fi
+fi
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="https://www.cups.org/ https://github.com/OpenPrinting/cups"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="acl dbus debug kerberos pam selinux +ssl static-libs systemd usb X xinetd zeroconf"
+
+# Upstream includes an interactive test which is a nono for Gentoo
+RESTRICT="test"
+
+BDEPEND="
+ acct-group/lp
+ acct-group/lpadmin
+ virtual/pkgconfig
+"
+DEPEND="
+ app-text/libpaper
+ sys-libs/zlib
+ acl? (
+ kernel_linux? (
+ sys-apps/acl
+ sys-apps/attr
+ )
+ )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ pam? ( sys-libs/pam )
+ !pam? ( virtual/libcrypt:= )
+ ssl? ( >=net-libs/gnutls-2.12.23-r6:0=[${MULTILIB_USEDEP}] )
+ systemd? ( sys-apps/systemd )
+ usb? ( virtual/libusb:1 )
+ X? ( x11-misc/xdg-utils )
+ xinetd? ( sys-apps/xinetd )
+ zeroconf? ( >=net-dns/avahi-0.6.31-r2[dbus,${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}
+ acct-group/lp
+ acct-group/lpadmin
+ selinux? ( sec-policy/selinux-cups )
+"
+PDEPEND=">=net-print/cups-filters-1.0.43"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.1-nostrip.patch"
+ "${FILESDIR}/${PN}-2.4.1-user-AR.patch"
+ "${FILESDIR}/${PN}-2.4.2-no-fortify-override.patch"
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/cups-config
+)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ if ! linux_config_exists; then
+ ewarn "Can't check the linux kernel configuration."
+ ewarn "You might have some incompatible options enabled."
+ else
+ # Recheck that we don't have usblp to collide with libusb; this should now work in most cases (bug #501122)
+ if use usb; then
+ if linux_chkconfig_present USB_PRINTER; then
+ elog "Your USB printers will be managed via libusb. In case you run into problems, "
+ elog "please try disabling USB_PRINTER support in your kernel or blacklisting the"
+ elog "usblp kernel module."
+ elog "Alternatively, just disable the usb useflag for cups (your printer will still work)."
+ fi
+ else
+ if ! linux_chkconfig_present USB_PRINTER; then
+ ewarn "If you plan to use USB printers you should enable the USB_PRINTER"
+ ewarn "support in your kernel."
+ ewarn "Please enable it:"
+ ewarn " CONFIG_USB_PRINTER=y"
+ ewarn "in /usr/src/linux/.config or"
+ ewarn " Device Drivers --->"
+ ewarn " USB support --->"
+ ewarn " [*] USB Printer support"
+ ewarn "Alternatively, enable the usb useflag for cups and use the libusb code."
+ fi
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Remove ".SILENT" rule for verbose output (bug #524338).
+ sed 's#^.SILENT:##g' -i Makedefs.in || die
+
+ AT_M4DIR="config-scripts" eautoreconf
+
+ # Custom Makefiles
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ export DSOFLAGS="${LDFLAGS}"
+
+ # Explicitly specify compiler wrt bug #524340
+ #
+ # Need to override KRB5CONFIG for proper flags
+ # https://github.com/apple/cups/issues/4423
+ local myeconfargs=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ KRB5CONFIG="${EPREFIX}"/usr/bin/${CHOST}-krb5-config
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --localstatedir="${EPREFIX}"/var
+ # Follow Fedora permission setting
+ --with-cupsd-file-perm=0755
+ --with-exe-file-perm=755
+ --with-log-file-perm=0640
+ # Used by Debian, also prevents printers from getting
+ # disabled and users not knowing how to re-enable them
+ --with-error-policy=retry-job
+ # Used in Debian and Fedora
+ --enable-sync-on-close
+ #
+ --with-rundir="${EPREFIX}"/run/cups
+ --with-cups-user=lp
+ --with-cups-group=lp
+ --with-docdir="${EPREFIX}"/usr/share/cups/html
+ --with-system-groups=lpadmin
+ --with-xinetd="${EPREFIX}"/etc/xinetd.d
+ $(multilib_native_use_enable acl)
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable debug debug-guards)
+ $(use_enable debug debug-printfs)
+ $(use_enable kerberos gssapi)
+ $(multilib_native_use_enable pam)
+ $(use_enable static-libs static)
+ $(use_with ssl tls gnutls)
+ $(use_with systemd ondemand systemd)
+ $(multilib_native_use_enable usb libusb)
+ $(use_with zeroconf dnssd avahi)
+ $(multilib_is_native_abi && echo --enable-libpaper || echo --disable-libpaper)
+ )
+
+ # Handle empty LINGUAS properly, bug #771162
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ myeconfargs+=(
+ --with-languages="${LINGUAS}"
+ )
+ fi
+
+ if tc-is-static-only; then
+ myeconfargs+=(
+ --disable-shared
+ )
+ fi
+
+ # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # makes more sense when facing multilib support.
+ sed -i -e 's:CUPS_SERVERBIN="$exec_prefix/lib/cups":CUPS_SERVERBIN="$exec_prefix/libexec/cups":g' configure ||die
+
+ econf "${myeconfargs[@]}"
+
+ sed -i -e "s:SERVERBIN.*:SERVERBIN = \"\$\(BUILDROOT\)${EPREFIX}/usr/libexec/cups\":" Makedefs || die
+ sed -i -e "s:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN \"${EPREFIX}/usr/libexec/cups\":" config.h || die
+ sed -i -e "s:cups_serverbin=.*:cups_serverbin=\"${EPREFIX}/usr/libexec/cups\":" cups-config || die
+
+ # Additional path corrections needed for prefix, see bug #597728
+ sed \
+ -e "s:ICONDIR.*:ICONDIR = ${EPREFIX}/usr/share/icons:" \
+ -e "s:INITDIR.*:INITDIR = ${EPREFIX}/etc:" \
+ -e "s:DBUSDIR.*:DBUSDIR = ${EPREFIX}/etc/dbus-1:" \
+ -e "s:MENUDIR.*:MENUDIR = ${EPREFIX}/usr/share/applications:" \
+ -i Makedefs || die
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake libs
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake BUILDROOT="${D}" install
+ else
+ emake BUILDROOT="${D}" install-libs install-headers
+ dobin cups-config
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,CREDITS,README}.md
+
+ # Move the default config file to docs
+ dodoc "${ED}"/etc/cups/cupsd.conf.default
+ rm "${ED}"/etc/cups/cupsd.conf.default || die
+
+ # Clean out cups init scripts
+ rm -r "${ED}"/etc/{init.d/cups,rc*} || die
+
+ # Install our init script
+ local neededservices=(
+ $(usex zeroconf avahi-daemon '')
+ $(usex dbus dbus '')
+ )
+ [[ -n ${neededservices[@]} ]] && neededservices="need ${neededservices[@]}"
+ cp "${FILESDIR}"/cupsd.init.d-r4 "${T}"/cupsd || die
+ sed -i -e "s/@neededservices@/${neededservices}/" "${T}"/cupsd || die
+ doinitd "${T}"/cupsd
+
+ if use pam ; then
+ rm "${ED}"/etc/pam.d/${PN} || die
+ pamd_mimic_system cups auth account
+ fi
+
+ if use xinetd ; then
+ # Correct path
+ sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" \
+ "${ED}"/etc/xinetd.d/cups-lpd || die
+ # It is safer to disable this by default, bug #137130
+ grep -w 'disable' "${ED}"/etc/xinetd.d/cups-lpd || \
+ { sed -i -e "s:}:\tdisable = yes\n}:" "${ED}"/etc/xinetd.d/cups-lpd || die ; }
+ # Write permission for file owner (root), bug #296221
+ fperms u+w /etc/xinetd.d/cups-lpd
+ else
+ # Always configure with --with-xinetd= and clean up later,
+ # bug #525604
+ rm -r "${ED}"/etc/xinetd.d || die
+ fi
+
+ keepdir /etc/cups/{interfaces,ppd,ssl}
+
+ if ! use X ; then
+ rm -r "${ED}"/usr/share/applications || die
+ fi
+
+ # Create /etc/cups/client.conf, bug #196967 and bug #266678
+ echo "ServerName ${EPREFIX}/run/cups/cups.sock" >> "${ED}"/etc/cups/client.conf
+
+ # The following file is now provided by cups-filter:
+ rm -r "${ED}"/usr/share/cups/banners || die
+
+ # The following are created by the init script
+ rm -r "${ED}"/var/cache || die
+ rm -r "${ED}"/run || die
+
+ keepdir /usr/libexec/cups/driver /usr/share/cups/{model,profiles} /var/log/cups /var/spool/cups/tmp
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ local v
+
+ for v in ${REPLACING_VERSIONS}; do
+ if ! ver_test ${v} -ge 2.2.2-r2 ; then
+ ewarn "The cupsd init script switched to using pidfiles. Shutting down"
+ ewarn "cupsd will fail the next time. To fix this, please run once as root"
+ ewarn " killall cupsd ; /etc/init.d/cupsd zap ; /etc/init.d/cupsd start"
+ break
+ fi
+ done
+
+ for v in ${REPLACING_VERSIONS}; do
+ elog
+ elog "For information about installing a printer and general cups setup"
+ elog "take a look at: https://wiki.gentoo.org/wiki/Printing"
+ break
+ done
+
+ optfeature_header "CUPS may need installing the following for certain features to work:"
+ use zeroconf && optfeature "local hostname resolution using a hostname.local naming scheme" sys-auth/nss-mdns
+}
diff --git a/net-print/cups/cups-9999.ebuild b/net-print/cups/cups-9999.ebuild
index bd33925c49a8..11e9e6c732a6 100644
--- a/net-print/cups/cups-9999.ebuild
+++ b/net-print/cups/cups-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
inherit autotools linux-info xdg multilib-minimal optfeature pam toolchain-funcs
MY_PV="${PV/_beta/b}"
@@ -11,13 +12,13 @@ MY_P="${PN}-${MY_PV}"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
-# EGIT_REPO_URI="https://github.com/apple/cups.git"
+ #EGIT_REPO_URI="https://github.com/apple/cups.git"
EGIT_REPO_URI="https://github.com/OpenPrinting/cups.git"
[[ ${PV} != 9999 ]] && EGIT_BRANCH=branch-${PV/.9999}
else
-# SRC_URI="https://github.com/apple/cups/releases/download/v${MY_PV}/${MY_P}-source.tar.gz"
+ #SRC_URI="https://github.com/apple/cups/releases/download/v${MY_PV}/${MY_P}-source.tar.gz"
SRC_URI="https://github.com/OpenPrinting/cups/releases/download/v${MY_PV}/cups-${MY_PV}-source.tar.gz"
- if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *_rc* ]] ; then
+ if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
fi
@@ -29,7 +30,7 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE="acl dbus debug kerberos pam selinux +ssl static-libs systemd usb X xinetd zeroconf"
-# upstream includes an interactive test which is a nono for gentoo
+# Upstream includes an interactive test which is a nono for Gentoo
RESTRICT="test"
BDEPEND="
@@ -67,6 +68,7 @@ PDEPEND=">=net-print/cups-filters-1.0.43"
PATCHES=(
"${FILESDIR}/${PN}-2.4.1-nostrip.patch"
"${FILESDIR}/${PN}-2.4.1-user-AR.patch"
+ "${FILESDIR}/${PN}-2.4.2-no-fortify-override.patch"
)
MULTILIB_CHOST_TOOLS=(
@@ -82,7 +84,7 @@ pkg_setup() {
ewarn "Can't check the linux kernel configuration."
ewarn "You might have some incompatible options enabled."
else
- # recheck that we don't have usblp to collide with libusb; this should now work in most cases (bug 501122)
+ # Recheck that we don't have usblp to collide with libusb; this should now work in most cases (bug #501122)
if use usb; then
if linux_chkconfig_present USB_PRINTER; then
elog "Your USB printers will be managed via libusb. In case you run into problems, "
@@ -91,7 +93,6 @@ pkg_setup() {
elog "Alternatively, just disable the usb useflag for cups (your printer will still work)."
fi
else
- #here we should warn user that he should enable it so he can print
if ! linux_chkconfig_present USB_PRINTER; then
ewarn "If you plan to use USB printers you should enable the USB_PRINTER"
ewarn "support in your kernel."
@@ -111,29 +112,21 @@ pkg_setup() {
src_prepare() {
default
- # Remove ".SILENT" rule for verbose output (bug 524338).
+ # Remove ".SILENT" rule for verbose output (bug #524338).
sed 's#^.SILENT:##g' -i Makedefs.in || die
- # Fix install-sh, posix sh does not have 'function'.
- sed 's#function gzipcp#gzipcp()#g' -i install-sh || die
-
- # Do not add -Werror even for live ebuilds
- sed '/WARNING_OPTIONS/s@-Werror@@' \
- -i config-scripts/cups-compiler.m4 || die
-
- AT_M4DIR=config-scripts eaclocal
- eautoconf
+ AT_M4DIR="config-scripts" eautoreconf
- # custom Makefiles
+ # Custom Makefiles
multilib_copy_sources
}
multilib_src_configure() {
export DSOFLAGS="${LDFLAGS}"
- # explicitly specify compiler wrt bug 524340
+ # Explicitly specify compiler wrt bug #524340
#
- # need to override KRB5CONFIG for proper flags
+ # Need to override KRB5CONFIG for proper flags
# https://github.com/apple/cups/issues/4423
local myeconfargs=(
CC="$(tc-getCC)"
@@ -173,7 +166,7 @@ multilib_src_configure() {
)
# Handle empty LINGUAS properly, bug #771162
- if [ -n "${LINGUAS+x}" ] ; then
+ if [[ -n "${LINGUAS+x}" ]] ; then
myeconfargs+=(
--with-languages="${LINGUAS}"
)
@@ -185,7 +178,7 @@ multilib_src_configure() {
)
fi
- # install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
# makes more sense when facing multilib support.
sed -i -e 's:CUPS_SERVERBIN="$exec_prefix/lib/cups":CUPS_SERVERBIN="$exec_prefix/libexec/cups":g' configure ||die
@@ -195,7 +188,7 @@ multilib_src_configure() {
sed -i -e "s:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN \"${EPREFIX}/usr/libexec/cups\":" config.h || die
sed -i -e "s:cups_serverbin=.*:cups_serverbin=\"${EPREFIX}/usr/libexec/cups\":" cups-config || die
- # additional path corrections needed for prefix, see bug 597728
+ # Additional path corrections needed for prefix, see bug #597728
sed \
-e "s:ICONDIR.*:ICONDIR = ${EPREFIX}/usr/share/icons:" \
-e "s:INITDIR.*:INITDIR = ${EPREFIX}/etc:" \
@@ -228,14 +221,14 @@ multilib_src_install() {
multilib_src_install_all() {
dodoc {CHANGES,CREDITS,README}.md
- # move the default config file to docs
+ # Move the default config file to docs
dodoc "${ED}"/etc/cups/cupsd.conf.default
rm "${ED}"/etc/cups/cupsd.conf.default || die
- # clean out cups init scripts
+ # Clean out cups init scripts
rm -r "${ED}"/etc/{init.d/cups,rc*} || die
- # install our init script
+ # Install our init script
local neededservices=(
$(usex zeroconf avahi-daemon '')
$(usex dbus dbus '')
@@ -251,16 +244,16 @@ multilib_src_install_all() {
fi
if use xinetd ; then
- # correct path
+ # Correct path
sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" \
"${ED}"/etc/xinetd.d/cups-lpd || die
- # it is safer to disable this by default, bug #137130
+ # It is safer to disable this by default, bug #137130
grep -w 'disable' "${ED}"/etc/xinetd.d/cups-lpd || \
{ sed -i -e "s:}:\tdisable = yes\n}:" "${ED}"/etc/xinetd.d/cups-lpd || die ; }
- # write permission for file owner (root), bug #296221
+ # Write permission for file owner (root), bug #296221
fperms u+w /etc/xinetd.d/cups-lpd
else
- # always configure with --with-xinetd= and clean up later,
+ # Always configure with --with-xinetd= and clean up later,
# bug #525604
rm -r "${ED}"/etc/xinetd.d || die
fi
@@ -271,13 +264,13 @@ multilib_src_install_all() {
rm -r "${ED}"/usr/share/applications || die
fi
- # create /etc/cups/client.conf, bug #196967 and #266678
+ # Create /etc/cups/client.conf, bug #196967 and bug #266678
echo "ServerName ${EPREFIX}/run/cups/cups.sock" >> "${ED}"/etc/cups/client.conf
- # the following file is now provided by cups-filters:
+ # The following file is now provided by cups-filter:
rm -r "${ED}"/usr/share/cups/banners || die
- # the following are created by the init script
+ # The following are created by the init script
rm -r "${ED}"/var/cache || die
rm -r "${ED}"/run || die
diff --git a/net-print/cups/files/cups-2.4.2-no-fortify-override.patch b/net-print/cups/files/cups-2.4.2-no-fortify-override.patch
new file mode 100644
index 000000000000..e9153ce2f082
--- /dev/null
+++ b/net-print/cups/files/cups-2.4.2-no-fortify-override.patch
@@ -0,0 +1,18 @@
+Gentoo already sets -D_FORTIFY_SOURCE=2 by default in GCC (patched in), so
+we need to avoid doing this in packages to avoid redefinition errors if
+we try to upgrade to e.g. =3.
+
+So, no effect on users, but important to stop issues w/ F_S=3.
+--- a/config-scripts/cups-compiler.m4
++++ b/config-scripts/cups-compiler.m4
+@@ -106,8 +106,8 @@ AS_IF([test -n "$GCC"], [
+ ], [
+ # Otherwise use the Fortify enhancements to catch any unbounded
+ # string operations...
+- CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
+- CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2"
++ CFLAGS="$CFLAGS"
++ CXXFLAGS="$CXXFLAGS"
+ ])
+
+ # Default optimization options...