summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-06 11:00:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-06 13:19:56 +0200
commit66ebe8d7b31478cb9f45ce2ea7ab55eb45d97363 (patch)
tree6b5c5c98d6a2fc3d5c75706f78b6075320e59291
parentdev-python/crashtest: Port to python3.10 (diff)
downloadgentoo-66ebe8d7.tar.gz
gentoo-66ebe8d7.tar.bz2
gentoo-66ebe8d7.zip
dev-python/pytest-mock: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.6.0.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
index c63a62d05f00..074f1d7ea000 100644
--- a/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
@@ -14,11 +13,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
-IUSE=""
RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
distutils_enable_tests pytest