summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-05-12 14:05:48 -0700
committerZac Medico <zmedico@gentoo.org>2024-05-12 14:05:52 -0700
commit67005ff6f266e22f7ce15b39fbf4d365a9a8e511 (patch)
treec9e07628cabddbff42d646a4242384892d6c5c1f
parentnet-misc/passt: update to 2024.05.10, cleanup (diff)
downloadgentoo-67005ff6f266e22f7ce15b39fbf4d365a9a8e511.tar.gz
gentoo-67005ff6f266e22f7ce15b39fbf4d365a9a8e511.tar.bz2
gentoo-67005ff6f266e22f7ce15b39fbf4d365a9a8e511.zip
net-dns/coredns: drop 1.11.2
Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--net-dns/coredns/Manifest1
-rw-r--r--net-dns/coredns/coredns-1.11.2.ebuild121
2 files changed, 0 insertions, 122 deletions
diff --git a/net-dns/coredns/Manifest b/net-dns/coredns/Manifest
index 9f5b7a662200..7b64f21dc6ff 100644
--- a/net-dns/coredns/Manifest
+++ b/net-dns/coredns/Manifest
@@ -1,3 +1,2 @@
-DIST coredns-1.11.2-deps.tar.xz 261482588 BLAKE2B 39e30800ac1fc404dc60f859b929c4a69614b9f0be8937c3fd7b1a872ec1e163ab4f6a313ed7661d2a101318187aaa2419168c0511cf2108c43ada38db0d1e0b SHA512 91282766d10d28d564d14fb20d8d82808507e509c58b7bb1959bb03a2665a287057aa4d547bfc8cc60ff080eea807af1c57d86bf9ff000125ef0642d8557e47f
DIST coredns-1.11.2-r1-deps.tar.xz 6547080 BLAKE2B 19a067a5b402ebe3b8a462e534bbdcf9baade4b5f434c6f24fe8ede0cbe623e2d5d8bdf0ffc06954d796441095688f19caa40f2255a2cc56102fdef36d327ac5 SHA512 caf6e0f1c9be4857059244019d6556f907e4f6907a932c201c856355c3e0b86c1752a90a226d5904c511d0db08ce4869cc5d24203bb4b9e2e1be02e725990332
DIST coredns-1.11.2.tar.gz 651994 BLAKE2B 1a7a272756eaf83170e242a573c8a765d6ea7b70fe422d36a87850b600a88287291aa0fe0d49462c34453d4d3c4d33f9497be409379ff8fccc87f41e2195efc1 SHA512 0e90ef4793555bd46aa5ce84cf639c015d1869b407627c69746eb948abff1920f891c45e5f00c0127f23e2c6394c07cc55c1776af840881210f90faa6ec22b40
diff --git a/net-dns/coredns/coredns-1.11.2.ebuild b/net-dns/coredns/coredns-1.11.2.ebuild
deleted file mode 100644
index 89d7e8f271e2..000000000000
--- a/net-dns/coredns/coredns-1.11.2.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module multiprocessing systemd tmpfiles toolchain-funcs
-
-DESCRIPTION="CoreDNS is a DNS server that chains plugins"
-HOMEPAGE="https://github.com/coredns/coredns"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/coredns/coredns.git"
-else
- #SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- # The v1.11.2 tag went missing upstream, so use a previously fetched copy.
- SRC_URI="https://dev.gentoo.org/~zmedico/dist/${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
- KEYWORDS="amd64"
-fi
-
-# main
-LICENSE="Apache-2.0"
-# deps
-LICENSE+=" MIT BSD ISC MPL-2.0 BSD-2"
-
-SLOT="0"
-IUSE="test"
-# TODO: debug test failure with deps tarball
-RESTRICT="test"
-
-RDEPEND="acct-user/coredns
- acct-group/coredns"
-
-FILECAPS=(
- -m 755 'cap_net_bind_service=+ep' usr/bin/${PN}
-)
-
-src_unpack() {
- if [[ ${PV} == *9999* ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- else
- go-module_src_unpack
- fi
-}
-
-src_prepare() {
- default
- use test || sed -i -e 's|coredns: $(CHECKS)|coredns:|' Makefile
-}
-
-src_compile() {
- # For non-live versions, prevent git operations which causes sandbox violations
- # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
- [[ ${PV} != 9999* ]] && export GITCOMMIT=''
-
- # Mimicking go-module.eclass's GOFLAGS
- if use amd64 || use arm || use arm64 ||
- ( use ppc64 && [[ $(tc-endian) == "little" ]] ) || use s390 || use x86; then
- local buildmode="-buildmode=pie"
- fi
- export BUILDOPTS="-buildvcs=false -modcacherw -v -x -p=$(makeopts_jobs) ${buildmode}"
-
- default
-}
-
-src_install() {
- dobin "${PN}"
- einstalldocs
- doman man/*
-
- newinitd "${FILESDIR}"/coredns.initd coredns
- newconfd "${FILESDIR}"/coredns.confd coredns
-
- insinto /etc/coredns/
- newins "${FILESDIR}"/Corefile.example Corefile
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/coredns.logrotated coredns
-
- systemd_dounit "${FILESDIR}"/coredns.service
- newtmpfiles "${FILESDIR}"/coredns.tmpfiles "${PN}.conf"
-}
-
-src_test() {
- # eclass default '-x' makes tests output unreadable
- export GOFLAGS="-v -mod=readonly"
-
- local known_fail=(
- "TestZoneExternalCNAMELookupWithProxy"
- "TestMetricsSeveralBlocs"
- "TestMetricsAvailable"
- "TestMetricsAvailableAfterReload"
- "TestMetricsAvailableAfterReloadAndFailedReload"
- )
- # concat as '|^Test1$|^Test2$|^Test3...$':
- local known_fail_re="$(printf '|^%s$' "${known_fail[@]}")"
- # drop '|' in the begining:
- known_fail_re="${known_fail_re:1}"
-
- local working_tests_re="$(
- # get list of all test:
- { GOFLAGS="-mod=readonly" go test -list . ./... ||
- die "Can't get list of tests"; } |
- # skip "no tests" messages as well as know failures:
- grep -v -E " |${known_fail_re}" |
- # format a regexp:
- sed -z 's/\n/$|^/g'
- )"
- # drop '|^' in the end:
- working_tests_re="^${working_tests_re::-2}"
-
- go test -race -run "${working_tests_re}" ./... || die "Tests failed"
- go test -race -run "${known_fail_re}" ./... || ewarn "Known test failure"
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
- tmpfiles_process ${PN}.conf
-}