summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Shkardoon <ss23@ss23.geek.nz>2020-01-08 05:34:59 +1300
committerJoonas Niilola <juippis@gentoo.org>2020-01-09 08:01:05 +0200
commit670a714944c0ab53d0294d8a1b5264621c0272ec (patch)
treed7345351ba899ce63f29b79b080f5ca073b693fc
parentx11-terms/kitty: remove redundant IUSE (diff)
downloadgentoo-670a714944c0ab53d0294d8a1b5264621c0272ec.tar.gz
gentoo-670a714944c0ab53d0294d8a1b5264621c0272ec.tar.bz2
gentoo-670a714944c0ab53d0294d8a1b5264621c0272ec.zip
media-tv/plex-media-server: Bump to 1.18.4
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Stephen Shkardoon <ss23@ss23.geek.nz> Closes: https://github.com/gentoo/gentoo/pull/14279 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-tv/plex-media-server/Manifest2
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.18.4.ebuild135
2 files changed, 137 insertions, 0 deletions
diff --git a/media-tv/plex-media-server/Manifest b/media-tv/plex-media-server/Manifest
index 03de430cdcb1..c2d6d34d1a7b 100644
--- a/media-tv/plex-media-server/Manifest
+++ b/media-tv/plex-media-server/Manifest
@@ -3,3 +3,5 @@ DIST plexmediaserver_1.14.1.5488-cc260c476_amd64.deb 105175642 BLAKE2B 59f7cc130
DIST plexmediaserver_1.16.4.1469-6d5612c2f_amd64.deb 74427444 BLAKE2B f90973aaadaf8e11fbcaa0aaa817a11b62049b1eaa22c04daf65d4fc21e73eb90d982e3faa66b482fdb4e7b53467246e20845c432920718334c5419c760e85bd SHA512 0753e82d4cd2c5a35f8f62329c3013eff297edd1bf9afcfd1444c3f3f85d33b3aec4a553c70931182d3a45df44dd26ce10ddbee9b59755914c988f0edbe5aa70
DIST plexmediaserver_1.18.3.2156-349e9837e_amd64.deb 87197768 BLAKE2B 1dfb42a0258c5a4ff93ac38ab4abad5c17ba3c0a26db85554fa43c72ad46416bcd15bea2a33114a17ed59a73c1b4b74953560f15db3df7eb8e00f3aeb090d4d4 SHA512 82920a25b6a73d929ee2dc776ae025d427248513b1590cef80224a2173c70f6354ec32a27d3e8e49d5f67ff3c77c57531a55d031a03fbd82034c301aa99a71ac
DIST plexmediaserver_1.18.3.2156-349e9837e_i386.deb 74116200 BLAKE2B fd5b152704c9c646fce9e2a139c0ac9d500d2514e2fc050d788bd5a65df55df4d7db8b17b0160623738add3f8ca29d3566741cf3c47866d09ac96f4e035e9fa0 SHA512 4a489b807e5f6b0624a879e29eac6816a3dbd31eb8286c76263904c59c7be481dfd6754a5e14ba6ee2247c851cfd0762ca3e4a3004ca5b343bf53a5a1e143552
+DIST plexmediaserver_1.18.4.2171-ac2afe5f8_amd64.deb 86833802 BLAKE2B a59b1ff4f4475b87464e6a7fe441258c95e19db86649bfb5110a1f1a2a5382c847a9d146dec48b726bd8d34622da04dfc31d460f9c91f44f551ab5a87e8ff4ec SHA512 b2106a43996ebbddd179101ab7c054ca7576f6cd60892c78354106875a13e22283fdcddfe39041acc2dc60690a40029edd213651938b04f002fe3680da13d707
+DIST plexmediaserver_1.18.4.2171-ac2afe5f8_i386.deb 73659238 BLAKE2B 3be12b14359f0e7f46f40328414855ece7c36d4cdd0c01dc30cf225ec3e7aef06504b8c2117f634e4ea0960aa387e2d2cfacb2e697d788befa1b76bc973aebf8 SHA512 9641ff170ea3379cf0b6351167206b2923194e831868b1c2245da7bd3a63af12f17ba27c42bd4b4cb8f00bb844e1be6b7427912d1f06096c6e701f579f918d66
diff --git a/media-tv/plex-media-server/plex-media-server-1.18.4.ebuild b/media-tv/plex-media-server/plex-media-server-1.18.4.ebuild
new file mode 100644
index 000000000000..994795f17759
--- /dev/null
+++ b/media-tv/plex-media-server/plex-media-server-1.18.4.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils systemd unpacker pax-utils python-single-r1
+
+MINOR_VERSION="2171-ac2afe5f8"
+
+_APPNAME="plexmediaserver"
+_USERNAME="plex"
+_SHORTNAME="${_USERNAME}"
+_FULL_VERSION="${PV}.${MINOR_VERSION}"
+
+URI="https://downloads.plex.tv/plex-media-server-new"
+
+DESCRIPTION="A free media library that is intended for use with a plex client"
+HOMEPAGE="https://www.plex.tv/"
+SRC_URI="
+ amd64? ( ${URI}/${_FULL_VERSION}/debian/plexmediaserver_${_FULL_VERSION}_amd64.deb )
+ x86? ( ${URI}/${_FULL_VERSION}/debian/plexmediaserver_${_FULL_VERSION}_i386.deb )
+"
+SLOT="0"
+LICENSE="Plex"
+RESTRICT="bindist strip"
+KEYWORDS="-* ~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="dev-python/virtualenv[${PYTHON_USEDEP}]"
+BDEPEND="dev-util/patchelf"
+
+RDEPEND="
+ acct-group/plex
+ acct-user/plex
+ net-dns/avahi
+ ${PYTHON_DEPS}"
+
+QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
+QA_PREBUILT="*"
+QA_MULTILIB_PATHS=(
+ "usr/lib/${_APPNAME}/.*"
+ "usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
+)
+
+BINS_TO_PAX_MARK=(
+ "${ED}/usr/lib/plexmediaserver/Plex Script Host"
+ "${ED}/usr/lib/plexmediaserver/Plex Media Scanner"
+)
+
+S="${WORKDIR}"
+PATCHES=(
+ "${FILESDIR}/virtualenv_start_pms_2019.patch"
+ "${FILESDIR}/plexmediamanager.desktop.new.patch"
+ "${FILESDIR}/add_gentoo_profile_as_platform_version.patch"
+)
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ # Move the config to the correct place
+ local config_vanilla="/etc/default/plexmediaserver"
+ local config_path="/etc/${_SHORTNAME}"
+ dodir "${config_path}"
+ insinto "${config_path}"
+ doins "${config_vanilla#/}"
+ sed -e "s#${config_vanilla}#${config_path}/${_APPNAME}#g" -i "${S}"/usr/sbin/start_pms || die
+
+ # Remove Debian specific files
+ rm -r "usr/share/doc" || die
+
+ # Copy main files over to image and preserve permissions so it is portable
+ cp -rp usr/ "${ED}"/ || die
+
+ # Make sure the logging directory is created
+ local logging_dir="/var/log/pms"
+ dodir "${logging_dir}"
+ fowners "${_USERNAME}":"${_USERNAME}" "${logging_dir}"
+ keepdir "${logging_dir}"
+
+ # Create default library folder with correct permissions
+ local default_library_dir="/var/lib/${_APPNAME}"
+ dodir "${default_library_dir}"
+ fowners "${_USERNAME}":"${_USERNAME}" "${default_library_dir}"
+ keepdir "${default_library_dir}"
+
+ # Install the OpenRC init/conf files
+ doinitd "${FILESDIR}/init.d/${PN}"
+ doconfd "${FILESDIR}/conf.d/${PN}"
+
+ # Mask Plex libraries so that revdep-rebuild doesn't try to rebuild them.
+ # Plex has its own precompiled libraries.
+ _mask_plex_libraries_revdep
+
+ # Fix RPATH
+ patchelf --force-rpath --set-rpath '$ORIGIN:$ORIGIN/../../../../../../lib' "${ED}"/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/lib-dynload/_codecs_kr.so || die
+
+ # Install systemd service file
+ systemd_newunit "${FILESDIR}/systemd/${PN}.service" "${PN}.service"
+
+ # Add pax markings to some binaries so that they work on hardened setup
+ for f in "${BINS_TO_PAX_MARK[@]}"; do
+ pax-mark m "${f}"
+ done
+
+ einfo "Configuring virtualenv"
+ virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"/usr/lib/plexmediaserver/Resources/Python || die
+ pushd "${ED}"/usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
+ find . -type f -exec sed -i -e "s#${D}##g" {} + || die
+ popd &>/dev/null || die
+}
+
+pkg_postinst() {
+ elog "Plex Media Server is now installed. Please check the configuration"
+ elog "file in /etc/${_SHORTNAME}/${_APPNAME}"
+ elog "to verify the default settings."
+ elog "To start the Plex Server, run 'rc-config start plex-media-server',"
+ elog "you will then be able to access your library at"
+ elog "http://<ip>:32400/web/"
+}
+
+# Adds the precompiled plex libraries to the revdep-rebuild's mask list
+# so it doesn't try to rebuild libraries that can't be rebuilt.
+_mask_plex_libraries_revdep() {
+ dodir /etc/revdep-rebuild/
+
+ # Bug: 659702. The upstream plex binary installs its precompiled package to /usr/lib.
+ # Due to profile 17.1 splitting /usr/lib and /usr/lib64, we can no longer rely
+ # on the implicit symlink automatically satisfying our revdep requirement when we use $(get_libdir).
+ # Thus we will match upstream's directory automatically. If upstream switches their location,
+ # then so should we.
+ echo "SEARCH_DIRS_MASK=\"${EPREFIX}/usr/lib/plexmediaserver\"" > "${ED}"/etc/revdep-rebuild/80plexmediaserver
+}