summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 14:46:37 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 15:02:26 +0200
commit6713fafe395a5489d3bea6880be339792e4a0519 (patch)
treef7c255f46fbe580e5722dc53144595ddcad8734f
parentx11-wm/fvwm: Ensure utf8 works always (#602276), use eapi7 (diff)
downloadgentoo-6713fafe.tar.gz
gentoo-6713fafe.tar.bz2
gentoo-6713fafe.zip
app-dicts/myspell-nl: Fix regions (#607080 by Erik Quaeghebeur)
Closes: https://bugs.gentoo.org/607080 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-dicts/myspell-nl/myspell-nl-2.10g-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-dicts/myspell-nl/myspell-nl-2.10g-r1.ebuild b/app-dicts/myspell-nl/myspell-nl-2.10g-r1.ebuild
new file mode 100644
index 000000000000..896c93bf5d55
--- /dev/null
+++ b/app-dicts/myspell-nl/myspell-nl-2.10g-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ "nl.aff"
+ "nl.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_nl.dic"
+)
+
+MYSPELL_THES=(
+ "th_nl_v2.dat"
+ "th_nl_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Dutch dictionaries for myspell/hunspell"
+HOMEPAGE="https://www.opentaal.org"
+# Thesarus is not versioned at all, I suppose we could bump it with each dict
+# release, or when people say that the download uri checksum changed.
+SRC_URI="
+ https://www.opentaal.org/bestanden/license_result/20-woordenlijst-v-${PV//./}-voor-openofficeorg-3?bid=20&agree=1 -> ${P}.oxt
+ https://data.opentaal.org/opentaalbank/thesaurus/download/thes_nl.oxt -> ${P}_thes.oxt
+"
+
+LICENSE="BSD-2 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ default
+ # Fix regions, bug #607080
+ mv nl_NL.aff nl.aff || die
+ mv nl_NL.dic nl.dic || die
+ mv hyph_nl_NL.dic hyph_nl.dic || die
+
+ # remove dutch translated license so it aint installed
+ rm -rf licentie* || die
+}