summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-08-28 14:06:17 +0200
committerAgostino Sarubbo <ago@gentoo.org>2023-08-28 14:06:17 +0200
commit6723227e7130fd195a8d4ef7300a51021962ec24 (patch)
treec3d282c7a33b676a24a540d400d5150537deba4d
parentx11-terms/kitty: depend on harfbuzz[truetype] (diff)
downloadgentoo-6723227e7130fd195a8d4ef7300a51021962ec24.tar.gz
gentoo-6723227e7130fd195a8d4ef7300a51021962ec24.tar.bz2
gentoo-6723227e7130fd195a8d4ef7300a51021962ec24.zip
app-admin/exo: version bump to 1.72.1
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.72.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 2e9eba55c16b..d6c5ca8f1c54 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.71.2.gh.tar.gz 5882010 BLAKE2B 11411544ae41b63f5236ae0710a4991edac2ab8a358752c409006818f3beee8d834f2270d9416a79fc3b90a6e9286f783f6c1a5dea18fc89ac8fa32fd909fcdb SHA512 58ed35125e7b0d86b43370f5361031a2229031766d5960b8620cd36314b006952ac3ca1f33e9548d0fdd6fbf5bc1a3ae3291ef712ad610bf4eb7e32273d9bc10
+DIST exo-1.72.1.gh.tar.gz 4981077 BLAKE2B eb4d5d4d925e4ef24e33c01f78cd2ecebcb7e3a599e3f4409ac908f68a0b99076f25405d830fe4a9866c56f9db2b91cd324f692b6977d457722f55395cb961a1 SHA512 37d6cb479a675b0463efb534b6ddf298b3e784c663678b4b8484e0bcd1e864d5f0aac4b2347c6967d4016da49fa1ffe4c6666347e31eecc6a8bb8a6f807f08c8
diff --git a/app-admin/exo/exo-1.72.1.ebuild b/app-admin/exo/exo-1.72.1.ebuild
new file mode 100644
index 000000000000..aee98d607c89
--- /dev/null
+++ b/app-admin/exo/exo-1.72.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit=" || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}