summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-03 15:23:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-03 15:43:37 +0200
commit672482e9799801839773c26a248ebe3fca6c6ef1 (patch)
tree02e7e9a859b2fa1ec0e19486257863ec1b19c828
parentmedia-gfx/gnofract4d: version bump to 4.3_p20200821 (diff)
downloadgentoo-672482e9.tar.gz
gentoo-672482e9.tar.bz2
gentoo-672482e9.zip
net-im/prosody: bump to version 0.11.7
Changes: Dropped useflag ipv6, since old non ipv6 dependency does not exist anymore. Renamed lua to luajit to use gentoos default. Added optional postgresql dependency to init script. Overhauled ebuild. Dropped multilib inherit, as it's not being used. Updated deps for correct luaexpat. Closes: https://bugs.gentoo.org/564434 Closes: https://bugs.gentoo.org/674842 Closes: https://bugs.gentoo.org/740662 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-im/prosody/Manifest1
-rw-r--r--net-im/prosody/files/prosody.initd-r346
-rw-r--r--net-im/prosody/prosody-0.11.7.ebuild79
3 files changed, 126 insertions, 0 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index a0adccc13376..ded27dd5ec24 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -1 +1,2 @@
DIST prosody-0.11.5.tar.gz 425122 BLAKE2B d65720a0c9d533a4be70847b690ecf037ae4b2fcbd090c81e2346d515599f3f148061103df2ffe46122a55694a3d35d53ab2b379fb5fb317e3b84a0ff5e82c29 SHA512 43a9facee8d61b69e277e7e8a9091fbfa60be71d6141195dff991f6020c8afadacce26f356b869cb2d7edd9be285e9ce1bcd822f9628cc845d91757e818a0dff
+DIST prosody-0.11.7.tar.gz 429369 BLAKE2B 8ef7377810702d5e1f480d84c09d6e3cc6aab674cca56fc1ce5e211d32df63ffeb57869c9d98429a81ea715ee19fca2ac015daa6b88b8c140efbeccb906defa6 SHA512 923aa92598ef851ed8408931942859f78f1e3d700fee251f4f5ca67abdcdae43448318ed90a9a1cdc7824d5f4dc5a4732fad4b9ed36d97455fa9b3bff0881a20
diff --git a/net-im/prosody/files/prosody.initd-r3 b/net-im/prosody/files/prosody.initd-r3
new file mode 100644
index 000000000000..3126cc8e1e20
--- /dev/null
+++ b/net-im/prosody/files/prosody.initd-r3
@@ -0,0 +1,46 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Prosody is a server for Jabber/XMPP written in Lua."
+description_reload="Reload configuration and reopen log files."
+extra_started_commands="reload"
+pidfile="/var/run/jabber/prosody.pid"
+
+depend() {
+ need net
+ provide jabber-server
+ use dns postgresql
+}
+
+checkconfig() {
+ if [ ! -e /etc/jabber/prosody.cfg.lua ] ; then
+ eerror "You need a /etc/jabber/prosody.cfg.lua file to run prosody"
+ return 1
+ fi
+ luac -p /etc/jabber/prosody.cfg.lua
+ return $?
+}
+
+start() {
+ checkconfig || return 1
+ checkpath -q -d -m 0770 -o jabber:jabber "$(dirname ${pidfile})"
+ checkpath -q -f -m 0770 -o jabber:jabber "${pidfile}"
+ checkpath -q -d -m 0750 -o jabber:jabber /var/log/jabber
+ ebegin "Starting Prosody XMPP Server"
+ prosodyctl start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Prosody XMPP Server"
+ prosodyctl stop
+ eend $?
+}
+
+reload() {
+ checkconfig || return 1
+ ebegin "Reloading configuration of Prosody XMPP Server"
+ prosodyctl reload
+ eend $?
+}
diff --git a/net-im/prosody/prosody-0.11.7.ebuild b/net-im/prosody/prosody-0.11.7.ebuild
new file mode 100644
index 000000000000..7d39dc0434fb
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.7.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libevent libressl luajit mysql postgres sqlite ssl test zlib"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-lua/LuaBitOp
+ net-dns/libidn
+ net-im/jabber-base
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( dev-lang/lua:0 )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ test? ( dev-lua/busted )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ ~dev-lua/luaexpat-1.3.0
+ dev-lua/luafilesystem
+ dev-lua/luasocket
+ libevent? ( dev-lua/luaevent )
+ mysql? ( dev-lua/luadbi[mysql] )
+ postgres? ( dev-lua/luadbi[postgres] )
+ sqlite? ( dev-lua/luadbi[sqlite] )
+ ssl? ( dev-lua/luasec )
+ zlib? ( dev-lua/lua-zlib )
+"
+
+PATCHES=( "${FILESDIR}/prosody_cfg-0.11.2-r1.patch" )
+
+src_configure() {
+ local myconfargs=(
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/spool/jabber"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="$(usex luajit luajit lua)"
+ --sysconfdir="${EPREFIX}/etc/jabber"
+ --with-lua-include="${EPREFIX}/usr/include"
+ --with-lua-lib="${EPREFIX}/usr/$(get_libdir)/lua"
+ )
+
+ ./configure ${myconfargs[@]} --cflags="${CFLAGS} -Wall -fPIC" --ldflags="${LDFLAGS} -shared" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ keepdir /var/spool/jabber
+
+ newinitd "${FILESDIR}"/prosody.initd-r3 prosody
+
+ systemd_dounit "${FILESDIR}"/prosody.service
+ systemd_newtmpfilesd "${FILESDIR}"/prosody.tmpfilesd prosody.conf
+
+ newinitd "${FILESDIR}"/prosody.initd-r3 prosody
+}