summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-30 18:59:43 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-03-30 19:03:20 -0700
commit6736748d52120902faf8fdf67507619a5f7780d1 (patch)
tree04288a170ace7bd6f05e4f4879f2841c8ef64a1c
parentRevert "dev-python/raet: enable py3.10" (diff)
downloadgentoo-6736748d52120902faf8fdf67507619a5f7780d1.tar.gz
gentoo-6736748d52120902faf8fdf67507619a5f7780d1.tar.bz2
gentoo-6736748d52120902faf8fdf67507619a5f7780d1.zip
dev-python/raet: Fix brokenness with a revision bump
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/raet/raet-0.6.8-r4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/raet/raet-0.6.8-r4.ebuild b/dev-python/raet/raet-0.6.8-r4.ebuild
new file mode 100644
index 000000000000..0d65a49ec907
--- /dev/null
+++ b/dev-python/raet/raet-0.6.8-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
+HOMEPAGE="https://github.com/RaetProtocol/raet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/libnacl-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-2.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/raet-0.6.8-msgpack-1.0.patch"
+ "${FILESDIR}/raet-0.6.8-py310.patch"
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "/setuptools_git/d" -i setup.py || die
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
+ popd || die
+}