summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Fan <alex.fan.q@gmail.com>2022-01-20 16:02:17 +1100
committerSam James <sam@gentoo.org>2022-01-20 12:30:58 +0000
commit675d894c36bfd854d8f7624912d34e9dd6ca7177 (patch)
tree6a8744483e381ba97f087e888b9332ceda5d9a60
parentdev-python/cython: Stabilize 0.29.26 ppc, #831546 (diff)
downloadgentoo-675d894c.tar.gz
gentoo-675d894c.tar.bz2
gentoo-675d894c.zip
dev-cpp/tbb: fix undefined __TBB_machine_fetchadd4
Closes: https://bugs.gentoo.org/827883 Signed-off-by: Alex Fan <alex.fan.q@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23878 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/tbb/files/tbb-2021.4.0-missing-TBB_machine_fetchadd4.patch23
-rw-r--r--dev-cpp/tbb/tbb-2021.4.0.ebuild2
-rw-r--r--dev-cpp/tbb/tbb-2021.5.0.ebuild2
3 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/tbb/files/tbb-2021.4.0-missing-TBB_machine_fetchadd4.patch b/dev-cpp/tbb/files/tbb-2021.4.0-missing-TBB_machine_fetchadd4.patch
new file mode 100644
index 000000000000..091cad5821e7
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-2021.4.0-missing-TBB_machine_fetchadd4.patch
@@ -0,0 +1,23 @@
+https://github.com/oneapi-src/oneTBB/issues/186
+https://github.com/oneapi-src/oneTBB/pull/550
+https://bugs.gentoo.org/827883
+
+From: Felix Yan <felixonmars@archlinux.org>
+Date: Thu, 7 Oct 2021 14:16:16 +0800
+Subject: [PATCH] Define ITT_ARCH_IA64 when undefiend (#550)
+
+Upstream-Status: Merged in commit later than 2021.5.0
+
+--- a/src/tbb/tools_api/ittnotify_config.h
++++ b/src/tbb/tools_api/ittnotify_config.h
+@@ -147,6 +147,10 @@
+ # define ITT_ARCH_IA32E 2
+ #endif /* ITT_ARCH_IA32E */
+
++#ifndef ITT_ARCH_IA64
++# define ITT_ARCH_IA64 3
++#endif /* ITT_ARCH_IA64 */
++
+ #ifndef ITT_ARCH_ARM
+ # define ITT_ARCH_ARM 4
+ #endif /* ITT_ARCH_ARM */
diff --git a/dev-cpp/tbb/tbb-2021.4.0.ebuild b/dev-cpp/tbb/tbb-2021.4.0.ebuild
index 930bcd958708..ff94b74527c2 100644
--- a/dev-cpp/tbb/tbb-2021.4.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.4.0.ebuild
@@ -24,6 +24,8 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-lto.patch
+ # bug 827883
+ "${FILESDIR}"/${P}-missing-TBB_machine_fetchadd4.patch
)
src_configure() {
diff --git a/dev-cpp/tbb/tbb-2021.5.0.ebuild b/dev-cpp/tbb/tbb-2021.5.0.ebuild
index 1fa9bfc11894..6b2ff50c7c4a 100644
--- a/dev-cpp/tbb/tbb-2021.5.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.5.0.ebuild
@@ -26,6 +26,8 @@ PATCHES=(
# should be in.. 2022?
"${FILESDIR}"/${PN}-2021.4.0-lto.patch
"${FILESDIR}"/${PN}-2021.5.0-musl-deepbind.patch
+ # bug 827883
+ "${FILESDIR}"/${PN}-2021.4.0-missing-TBB_machine_fetchadd4.patch
# need to verify this is in master
"${FILESDIR}"/${PN}-2021.5.0-musl-mallinfo.patch
)