summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-01-06 23:44:36 -0500
committerJoonas Niilola <juippis@gentoo.org>2024-02-07 15:59:30 +0200
commit677085fa88ff4f533465505cfb5f9d3bcdc57b84 (patch)
treedd83169ec4ba774ef95545f39eac94b918c3560c
parentmail-mta/postfix: add 3.9_pre20240206, drop 3.9_pre20240129 (diff)
downloadgentoo-677085fa88ff4f533465505cfb5f9d3bcdc57b84.tar.gz
gentoo-677085fa88ff4f533465505cfb5f9d3bcdc57b84.tar.bz2
gentoo-677085fa88ff4f533465505cfb5f9d3bcdc57b84.zip
sys-cluster/kops: add 1.28.2, security bump
Bug: https://bugs.gentoo.org/909091 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/34688 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-cluster/kops/Manifest1
-rw-r--r--sys-cluster/kops/kops-1.28.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-cluster/kops/Manifest b/sys-cluster/kops/Manifest
index c1852141e784..1babf1ef67f0 100644
--- a/sys-cluster/kops/Manifest
+++ b/sys-cluster/kops/Manifest
@@ -1 +1,2 @@
DIST kops-1.23.2.tar.gz 30376137 BLAKE2B 3d6e6a52202872df58436783736a996be49b764916c95926347ca2c4893beaf9977eb5102296e41e16256804fc457cc3eb24f6bfd7d0ab2de6f4a3af255f13e5 SHA512 9e221ed709ac3822ab29e78e3fa9de8b88c26184977eff6fc961d5c109b997c8dd842e3cee3eb8d8cc83e3a2250c95ec9e523b82ea7486b59930101e47f1937a
+DIST kops-1.28.2.tar.gz 34257531 BLAKE2B 2f91077bd7cfd5edfe35feb640da074827b5e9db7cf8040870c14a04aec42c38b2cabf13c1968e10aab8eeb40c30e37930aab1ee2766240ea5916256ac9d0fb7 SHA512 d982a984caba1380df919a7d128694546b25df1ce2ef258f84b02fac8ff7e5ac1ddb280e2760a62522508e07eab0cbd554013be2f4860b2078e488c04420e873
diff --git a/sys-cluster/kops/kops-1.28.2.ebuild b/sys-cluster/kops/kops-1.28.2.ebuild
new file mode 100644
index 000000000000..e5d60738b38f
--- /dev/null
+++ b/sys-cluster/kops/kops-1.28.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Kubernetes Operations"
+HOMEPAGE="https://kops.sigs.k8s.io/ https://github.com/kubernetes/kops/"
+SRC_URI="https://github.com/kubernetes/kops/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Failure needs investigation
+RESTRICT="test"
+
+src_compile() {
+ export GOBIN="${WORKDIR}/${P}/kops"
+
+ emake
+}
+
+src_install() {
+ dobin kops
+}