summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-09-13 22:49:23 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-10-02 11:42:30 +0300
commit67847442aeee9a7e684a53d0b47e65d680503ea9 (patch)
tree225fd023215ce53e759a5098730f52729019abc6
parentdev-libs/serd: bump to 0.30.6 (diff)
downloadgentoo-67847442.tar.gz
gentoo-67847442.tar.bz2
gentoo-67847442.zip
app-crypt/tpm2-totp: Bump to 0.3.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-crypt/tpm2-totp/Manifest1
-rw-r--r--app-crypt/tpm2-totp/metadata.xml3
-rw-r--r--app-crypt/tpm2-totp/tpm2-totp-0.3.0.ebuild51
3 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/tpm2-totp/Manifest b/app-crypt/tpm2-totp/Manifest
index 5e4f68674f25..85caafc9799f 100644
--- a/app-crypt/tpm2-totp/Manifest
+++ b/app-crypt/tpm2-totp/Manifest
@@ -1 +1,2 @@
DIST tpm2-totp-0.2.1.tar.gz 427226 BLAKE2B e6a9dbcdac4d7fc31048aff968e3eea097752c79a3c1b8551d22558a6b143a758e7bb507722185c648000f4b1edd2f0bbdd443890b5763b297f3d42cfbd84d9d SHA512 2bda34e89b76319a40206e08c0208b0f139309c0b0e40e7168b5e7562096750df504dfcae3a39e6f82fdccbf7a79ed0802d115fbd7560dc3f5b52d81fe8fb59c
+DIST tpm2-totp-0.3.0.tar.gz 428874 BLAKE2B 413f4418cd1ce9a996f36c83e27c3fe256b2d3f5ff36e7df1dc1b651e38afa222be9742d5cfa76287263a4e1402dabea3400b41a1e1bde9f31fe03f82894f4f1 SHA512 d47cc8155a60a464afe602c3114ff8e6b2ff825457e6069693947421716b97c34b00f70adbcb4cda1b5b9639b8a3dfc7800295bbff99822da7a8077ebf78d6b2
diff --git a/app-crypt/tpm2-totp/metadata.xml b/app-crypt/tpm2-totp/metadata.xml
index ff3a177c4bdd..fb1b2ed30d06 100644
--- a/app-crypt/tpm2-totp/metadata.xml
+++ b/app-crypt/tpm2-totp/metadata.xml
@@ -12,4 +12,7 @@
<upstream>
<remote-id type="github">tpm2-software/tpm2-totp</remote-id>
</upstream>
+ <use>
+ <flag name="plymouth">Add <pkg>sys-boot/plymouth</pkg> support</flag>
+ </use>
</pkgmetadata>
diff --git a/app-crypt/tpm2-totp/tpm2-totp-0.3.0.ebuild b/app-crypt/tpm2-totp/tpm2-totp-0.3.0.ebuild
new file mode 100644
index 000000000000..b02901ba1dcd
--- /dev/null
+++ b/app-crypt/tpm2-totp/tpm2-totp-0.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Attest the trustworthiness of a device against a human using time-based OTP"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-totp"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="plymouth test"
+
+REQUIRED_USE="test? ( plymouth )"
+
+RDEPEND="app-crypt/tpm2-tss
+ media-gfx/qrencode
+ plymouth? ( sys-boot/plymouth )"
+DEPEND="${RDEPEND}
+ test? (
+ app-crypt/swtpm
+ app-crypt/tpm2-tools
+ >=app-crypt/tpm2-tss-3.0.0
+ sys-apps/fakeroot
+ sys-auth/oath-toolkit
+ )"
+
+BDEPEND="virtual/pkgconfig"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-defaultflags \
+ $(use_enable plymouth) \
+ $(use_enable test integration)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}