summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 18:24:43 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 18:27:44 +0200
commit67a22279aee9a4adec1f5f90ff1487e82156d52c (patch)
tree98be3e299db02962c9c32a14bd5c3196dde38b30
parentRemove masked for removal package (diff)
downloadgentoo-67a22279aee9a4adec1f5f90ff1487e82156d52c.tar.gz
gentoo-67a22279aee9a4adec1f5f90ff1487e82156d52c.tar.bz2
gentoo-67a22279aee9a4adec1f5f90ff1487e82156d52c.zip
Revert "Remove masked for removal package"
This reverts commit 2d0b80ef059fd4c1ea78193385e4b22f92527b73.
-rw-r--r--games-arcade/sdlsasteroids/debug0
-rw-r--r--games-board/gnugo/learn.phalanxbin262144 -> 0 bytes
-rw-r--r--games-board/phalanx/bug.lrn0
-rw-r--r--games-board/phalanx/losers.lrn0
-rw-r--r--games-board/phalanx/standard.lrn0
-rw-r--r--games-board/phalanx/suicide.lrn0
-rw-r--r--games-fps/alephone-infinity/Manifest2
-rw-r--r--games-fps/alephone-infinity/alephone-infinity-20080622.ebuild40
-rw-r--r--games-fps/alephone-infinity/metadata.xml8
-rw-r--r--games-fps/alephone/Manifest1
-rw-r--r--games-fps/alephone/alephone-20150620-r1.ebuild88
-rw-r--r--games-fps/alephone/files/alephone.sh28
-rw-r--r--games-fps/alephone/metadata.xml12
-rw-r--r--profiles/package.mask5
14 files changed, 184 insertions, 0 deletions
diff --git a/games-arcade/sdlsasteroids/debug b/games-arcade/sdlsasteroids/debug
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/games-arcade/sdlsasteroids/debug
+++ /dev/null
diff --git a/games-board/gnugo/learn.phalanx b/games-board/gnugo/learn.phalanx
deleted file mode 100644
index 6d23118f0d00..000000000000
--- a/games-board/gnugo/learn.phalanx
+++ /dev/null
Binary files differ
diff --git a/games-board/phalanx/bug.lrn b/games-board/phalanx/bug.lrn
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/games-board/phalanx/bug.lrn
+++ /dev/null
diff --git a/games-board/phalanx/losers.lrn b/games-board/phalanx/losers.lrn
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/games-board/phalanx/losers.lrn
+++ /dev/null
diff --git a/games-board/phalanx/standard.lrn b/games-board/phalanx/standard.lrn
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/games-board/phalanx/standard.lrn
+++ /dev/null
diff --git a/games-board/phalanx/suicide.lrn b/games-board/phalanx/suicide.lrn
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/games-board/phalanx/suicide.lrn
+++ /dev/null
diff --git a/games-fps/alephone-infinity/Manifest b/games-fps/alephone-infinity/Manifest
new file mode 100644
index 000000000000..ffd3f5204e50
--- /dev/null
+++ b/games-fps/alephone-infinity/Manifest
@@ -0,0 +1,2 @@
+DIST MarathonInfinity.zip 30109883 BLAKE2B 5412c172e3f3066250912d9e818b172c9b036c4a71d090d36c3ef7e078d7e37ca7d676282176bd79d3e87b212d40245e7d16d0f8016a3094de24c4434570fdbd SHA512 1f347615b96d2c07914cda78bdc6971311f3933af78debfcd9fa87a0a3048220726a082602b7a76f516f7b3dd3240d1ea843794ab34e4e9e7733342d9d9fe5b1
+DIST alephone-infinity.png 19193 BLAKE2B c4e6eeb74d56798ebf3f96f2ee509fb6ac7d695e2c51e4f34599be507deb6354a0e034e0441ced4b5ad5688ec87a2129fdbded28b036e074737cc8dd0974683b SHA512 ad5c683aae4ee0afa306aaf33c9ad93a2eee59a4283166aada58a48a8dbbe8de62c8af0b04b143366448ef101ba8b2530cbc8bc5b3e1de62c5177775fae6bfd3
diff --git a/games-fps/alephone-infinity/alephone-infinity-20080622.ebuild b/games-fps/alephone-infinity/alephone-infinity-20080622.ebuild
new file mode 100644
index 000000000000..46cd7a3b526d
--- /dev/null
+++ b/games-fps/alephone-infinity/alephone-infinity-20080622.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Aleph One - Marathon Infinity"
+HOMEPAGE="http://trilogyrelease.bungie.org/"
+SRC_URI="http://files3.bungie.org/trilogy/MarathonInfinity.zip
+ mirror://gentoo/${PN}.png"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Marathon\ Infinity
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r *
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry "alephone.sh infinity" "Aleph One - Marathon Infinity"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${GAMES_DATADIR}"/${PN}/{Scripts,"Physics Models",Textures,Themes}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play this scenario, run:"
+ elog "alephone.sh infinity"
+}
diff --git a/games-fps/alephone-infinity/metadata.xml b/games-fps/alephone-infinity/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/alephone-infinity/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
new file mode 100644
index 000000000000..63f1b15b4acc
--- /dev/null
+++ b/games-fps/alephone/Manifest
@@ -0,0 +1 @@
+DIST AlephOne-20150620.tar.bz2 5031898 BLAKE2B 7f319c1b1ae2930e5ebfdf7baa1947d35e3f606e936fe86393cf26e1b9b7803283897811bf17cdb2f88931db606b3a13ed1f83bf9a8e9fed3b197135da0cbf46 SHA512 fb47969137b791f83b111171d7b92b3708597db294ce19fb682ce28c49edcd4cb84a6ce4dcceb6630812a8c676dfe7f39f3fb4642f40ef7086a0d6c6fdeba8df
diff --git a/games-fps/alephone/alephone-20150620-r1.ebuild b/games-fps/alephone/alephone-20150620-r1.ebuild
new file mode 100644
index 000000000000..4672cf9d6742
--- /dev/null
+++ b/games-fps/alephone/alephone-20150620-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=AlephOne-${PV}
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/AlephOne-${PV}.tar.bz2"
+
+LICENSE="GPL-3+ BitstreamVera OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="alsa curl ffmpeg mad mpeg sndfile speex vorbis"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/expat
+ dev-libs/zziplib
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,opengl,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ virtual/opengl
+ virtual/glu
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ ffmpeg? ( virtual/ffmpeg )
+ mad? ( media-libs/libmad )
+ mpeg? ( media-libs/smpeg )
+ sndfile? ( media-libs/libsndfile )
+ speex? ( media-libs/speex )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ sed "s:GAMES_DATADIR:/usr/share:g" \
+ "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
+ || die
+
+ # try using the system expat - bug #251108
+ sed -i \
+ -e '/SUBDIRS/ s/Expat//' \
+ -e 's/Expat\/libexpat.a/-lexpat/' \
+ Source_Files/Makefile.am || die
+ sed -i -e '/Expat/d' configure.ac || die
+ rm -r Source_Files/Expat || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-lua \
+ --enable-opengl \
+ $(use_with alsa) \
+ $(use_with ffmpeg) \
+ $(use_with mad) \
+ $(use_with mpeg smpeg) \
+ $(use_with sndfile) \
+ $(use_with speex) \
+ $(use_with vorbis)
+}
+
+src_install() {
+ default
+ dobin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ dodoc docs/*.html
+}
+
+pkg_postinst() {
+ echo
+ elog "Read the docs and install the data files accordingly to play."
+ echo
+ elog "If you only want to install one scenario, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Single_scenario_3"
+ elog "If you want to install multiple scenarios, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/files/alephone.sh b/games-fps/alephone/files/alephone.sh
new file mode 100644
index 000000000000..62ac98f85770
--- /dev/null
+++ b/games-fps/alephone/files/alephone.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+DIR=$(dirname "${0}")
+CMD=$(basename "${0}")
+ALEPHONE=${CMD%%.sh}
+
+if [[ -z "${1}" ]]
+then
+ echo "Usage: ${0} SCENARIO FLAGS"
+ echo "Where SCENARIO is one of:"
+ for d in "GAMES_DATADIR"/alephone-*
+ do
+ echo " ${d##*/alephone-}"
+ done
+ exit 2
+fi
+
+export ALEPHONE_DATA="GAMES_DATADIR/alephone-${1}"
+
+shift
+
+# kill ARTS, because we're just that nice
+if artsshell terminate 2> /dev/null
+then
+ sleep 2
+fi
+
+"${DIR}"/"${ALEPHONE}" "$@"
diff --git a/games-fps/alephone/metadata.xml b/games-fps/alephone/metadata.xml
new file mode 100644
index 000000000000..f7a55faa0217
--- /dev/null
+++ b/games-fps/alephone/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">marathon</remote-id>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 869836bbec21..625096ab773b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -477,6 +477,11 @@ x11-themes/icewm-themes
sys-freebsd/virtio-kmod
# Pacho Ramos <pacho@gentoo.org> (17 Mar 2018)
+# Doesn't build (#591918, #587392). Removal in a month.
+games-fps/alephone
+games-fps/alephone-infinity
+
+# Pacho Ramos <pacho@gentoo.org> (17 Mar 2018)
# Broken for a long time (#587806). Removal in a month.
app-text/zemberek-server
app-text/zpspell