summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 08:15:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 10:50:12 +0200
commit67a52ca8ca3a305d1e5820ae007f2239470cde78 (patch)
treeef81e8f9cc35add1e7b99023e5aecc94eb4b3cee
parentdev-python/pyspnego: Bump to 0.5.4 (diff)
downloadgentoo-67a52ca8ca3a305d1e5820ae007f2239470cde78.tar.gz
gentoo-67a52ca8ca3a305d1e5820ae007f2239470cde78.tar.bz2
gentoo-67a52ca8ca3a305d1e5820ae007f2239470cde78.zip
dev-python/pyelftools: Bump to 0.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyelftools/Manifest1
-rw-r--r--dev-python/pyelftools/pyelftools-0.29.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyelftools/Manifest b/dev-python/pyelftools/Manifest
index 44ad39ed6598..fb4ef060c6b5 100644
--- a/dev-python/pyelftools/Manifest
+++ b/dev-python/pyelftools/Manifest
@@ -1 +1,2 @@
DIST pyelftools-0.28.gh.tar.gz 5086001 BLAKE2B 87dad42d87b9d3de2382e21d6f7115fb24e420e262735d4bd73c4e3a325d10b69c6eab5d73ff999811633d6a024c22c15ad65be637339f0c609378d54926f747 SHA512 005163a53fe12baad0998d60d531e3ce4201236b7b042e3c28d7e68f9c40586f94a2576be6918be991a3bf464f2ca55700c0475a6e8c7b05b4342a6f5bbf3354
+DIST pyelftools-0.29.gh.tar.gz 14176561 BLAKE2B 441260492f8cd512445249700a79f1d823ef96f6213ab9183e17160b76efe51493c28d2ae8ecea79acf45e78987b4c24940441e9bc0a3deaeda0ee4fb72b58c3 SHA512 0eba3b029a734abe9f8df92cd58bc967f10bf9f61c3a419bdbc5e637200844dddd947bcb485e8ebbe2eeaa7f7e91efc6500316af51aace1db051a658cf61153e
diff --git a/dev-python/pyelftools/pyelftools-0.29.ebuild b/dev-python/pyelftools/pyelftools-0.29.ebuild
new file mode 100644
index 000000000000..919519a56c65
--- /dev/null
+++ b/dev-python/pyelftools/pyelftools-0.29.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
+HOMEPAGE="
+ https://pypi.org/project/pyelftools/
+ https://github.com/eliben/pyelftools/
+"
+# PyPI tarball lacks some test files
+SRC_URI="
+ https://github.com/eliben/pyelftools/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_test() {
+ # readelf_tests often fails due to host `readelf` changing output format
+ "${EPYTHON}" test/run_all_unittests.py || die
+ "${EPYTHON}" test/run_examples_test.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}