summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 11:34:48 +0000
committerSam James <sam@gentoo.org>2021-06-01 11:34:48 +0000
commit67ab3a9048ea9f4365c9e31668ecf2e45d3afd2b (patch)
tree69d3300c20b21ab7dd46a3cf8021b7fad476e884
parentapp-vim/pyclewn: add Python 3.9 (diff)
downloadgentoo-67ab3a9048ea9f4365c9e31668ecf2e45d3afd2b.tar.gz
gentoo-67ab3a9048ea9f4365c9e31668ecf2e45d3afd2b.tar.bz2
gentoo-67ab3a9048ea9f4365c9e31668ecf2e45d3afd2b.zip
app-vim/pydiction: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
index b17b9944fb34..aea6beb9b9f0 100644
--- a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
+++ b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit vim-plugin python-r1
DESCRIPTION="vim plugin: tab-complete your Python code"
HOMEPAGE="https://rkulla.github.io/pydiction/"
SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+S="${WORKDIR}/${PN}-master"
LICENSE="vim"
KEYWORDS="amd64 ppc ppc64 x86"
@@ -18,8 +19,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="app-arch/unzip"
RDEPEND="${PYTHON_DEPS}"
-S="${WORKDIR}/${PN}-master"
-
src_install() {
# Rename pydiction script.
mv "${PN}.py" "${PN}" || die