summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-26 13:42:34 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-26 13:42:34 +0000
commit67e02a1ba8aa9f38bae2bde574beed1a8e1ff8b2 (patch)
tree7547f620493d20964052a27c4acf6425021f60f1
parentdev-lang/elixir: bump up to 1.10.2 (diff)
downloadgentoo-67e02a1b.tar.gz
gentoo-67e02a1b.tar.bz2
gentoo-67e02a1b.zip
sys-devel/sparse: bump up to 0.6.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/sparse/Manifest1
-rw-r--r--sys-devel/sparse/sparse-0.6.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
index 894cb6a67508..0b6c7726fdd1 100644
--- a/sys-devel/sparse/Manifest
+++ b/sys-devel/sparse/Manifest
@@ -1,3 +1,4 @@
DIST sparse-0.5.1.tar.xz 215144 BLAKE2B 209aa7cf34a9135dae38466a0ba41ff4fb888c363ed59a68a5820d4b6ef1636d717b8172a6d638d9dbc61197efb7a3e06ef85830b6f1c359737520b4b3aa0fbe SHA512 f7fc516ef8343a4153b9bda1b50b326dcd55a77fce5acccd9aa4c5636d6510573c7e26b0a7ca1df847082faf2be2d292336ad1cec855e395703a6b1e04d3a8a1
DIST sparse-0.5.2-rc1.tar.gz 282810 BLAKE2B 74d06230ceb06dac427984c365223633ef795b2f6329c69da5183b9f3444457ee05d74b04b18cf400b4d813026a746218edbf9bc0b2aa371c8a3681ac10ce19b SHA512 b58458b97e91b7d02d032a946d9870a3fd227959608fb7847864ad1a92258aeb0461da513f4d6d3b37791ed8d5fc41ac01cfef0fcaf34b229090ff078672ef40
DIST sparse-0.6.0.tar.xz 284668 BLAKE2B 9bb568fe23ac96d6e179e5c5927ff34e9fc88909d367f6ab49c8862a8e599df83602ba72bc42ba3bf63823b024340f101128c528ebf767f4e29da7f5324a1f40 SHA512 5c6c88f203c941bf0efd28802ef91641c96e7d4b4688a5176d091ff0fd6a650d9147e590b631602a8bd08994a35261977569367861a6d605ccdd25e4a07debf9
+DIST sparse-0.6.1.tar.xz 287880 BLAKE2B 026e7770460ab576b91e8c401c642e95269ddd7c90c0f855b0246448ca653b95a899b4bf647134c090c06c802757b6415dcc89bc214fb7ff124c2ce3888fccb0 SHA512 2faad9b3263f19f941cd6a5891960d2c7d1066c664d3ef68e722d461785aeed2d4a9539df3556bbd98c022e7ee965b8030c49272ab6003113ba3b36f73c00187
diff --git a/sys-devel/sparse/sparse-0.6.1.ebuild b/sys-devel/sparse/sparse-0.6.1.ebuild
new file mode 100644
index 000000000000..8828d2b92304
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.6.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://www.kernel.org/pub/software/devel/${PN}/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gtk llvm test xml"
+RESTRICT="!test? ( test )"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( >=sys-devel/llvm-3.0 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+_emake() {
+ # Makefile does not allow for an easy override of flags.
+ # Collect them here and override default phases.
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ \
+ HAVE_GTK=$(usex gtk) \
+ HAVE_LLVM=$(usex llvm) \
+ HAVE_LIBXML=$(usex xml) \
+ \
+ V=1 \
+ PREFIX="${EPREFIX}/usr" \
+ \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+
+ dodoc FAQ README
+}