summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-03 15:56:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-04 09:45:57 +0200
commit67e951f9840c288393a12caf35929284f2683c2a (patch)
tree68db0615f193bb5fbb3e51e14bf39be4ac6151bc
parentnet-print/cups-filters: Removed old. (diff)
downloadgentoo-67e951f9.tar.gz
gentoo-67e951f9.tar.bz2
gentoo-67e951f9.zip
app-editors/okteta: 0.25.3 version bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.25.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index 79a06fb1f0b8..e458c9014a1e 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1,2 +1,3 @@
DIST okteta-0.25.1.tar.xz 951952 BLAKE2B 180cb7426b85cc8598f774d50556fe26d95d11e7c8b5be542a38fd4fa1c0479b401e6be59e7ca86eabba805c2a5d2ea2d818960cb218d173fd87db23f9c5525f SHA512 67e594ee1674176cbf506ca1191ced748bf6aec268d57211e052552f9673c359ccb3fefd403b5cf63e04f63a4fd3b42b0d21ef8eefcbac999081d58505df2174
DIST okteta-0.25.2.tar.xz 954124 BLAKE2B b880001d6351479accb2f5f2e00a2574337695642bf9082b030d1a56e828fa4cc8e4cf00c6781e12328a20fde004cddaad057b0dbce2fb34a243e24df48ee878 SHA512 78f905479dc5070754b53d8fb7374d162a64479303092ce3f391953a01332946d98151f181a6c9363c68dad7098b58909b4db53724fac9aa848606f9ff3b6511
+DIST okteta-0.25.3.tar.xz 950956 BLAKE2B d177db59b5327f4e75157c99fdac2191de9a7ef63433635ccf8f11ef4dc4ff201942c9f68383d720b18c26a9e7335bc1181ea4f0e36491b34b27e6c7dc469c9e SHA512 f27b0c2ca3c5f1ad838af847e08c53c8f8f3c386921bd2e0d5e833902659477196e6c6b72a428443e2be9013928c2151c1889ef33d59404815a34d81560ef2a7
diff --git a/app-editors/okteta/okteta-0.25.3.ebuild b/app-editors/okteta/okteta-0.25.3.ebuild
new file mode 100644
index 000000000000..89727e9e83b1
--- /dev/null
+++ b/app-editors/okteta/okteta-0.25.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}