summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-17 09:13:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-17 09:21:04 +0200
commit681418f8869b711cd52e9332766652a326122b9d (patch)
tree9d4a793cba2c70d1d5763d787492d3853cc22876
parentdev-python/webtest: Enable py3.11 (diff)
downloadgentoo-681418f8.tar.gz
gentoo-681418f8.tar.bz2
gentoo-681418f8.zip
dev-python/wsgiproxy2: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..c6dd4a0666d1
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="
+ https://github.com/gawel/WSGIProxy2/
+ https://pypi.org/project/WSGIProxy2/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest