summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-16 04:58:02 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-16 05:03:01 -0700
commit6814c4df07c0a0e31520130036e610705340e75d (patch)
tree9e9c16853179f2528ce241ae8dc69f542bd7144a
parentdev-python/xvfbwrapper: remove old (diff)
downloadgentoo-6814c4df07c0a0e31520130036e610705340e75d.tar.gz
gentoo-6814c4df07c0a0e31520130036e610705340e75d.tar.bz2
gentoo-6814c4df07c0a0e31520130036e610705340e75d.zip
x11-wm/qtile: add py38 support, use BDEPEND, and drop pytest-cov dep
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--x11-wm/qtile/qtile-0.14.2-r1.ebuild5
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/x11-wm/qtile/qtile-0.14.2-r1.ebuild b/x11-wm/qtile/qtile-0.14.2-r1.ebuild
index b9c5aecfceab..f3000cecff6d 100644
--- a/x11-wm/qtile/qtile-0.14.2-r1.ebuild
+++ b/x11-wm/qtile/qtile-0.14.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1 virtualx
@@ -32,10 +32,9 @@ RDEPEND="
>=dev-python/xcffib-0.8.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/xvfbwrapper[${PYTHON_USEDEP}]
x11-base/xorg-server[xephyr]
x11-apps/xeyes
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index b9c5aecfceab..f3000cecff6d 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1 virtualx
@@ -32,10 +32,9 @@ RDEPEND="
>=dev-python/xcffib-0.8.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/xvfbwrapper[${PYTHON_USEDEP}]
x11-base/xorg-server[xephyr]
x11-apps/xeyes