summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-05-15 10:30:33 -0400
committerMike Gilbert <floppym@gentoo.org>2024-05-15 10:31:10 -0400
commit6817a75995db17a403b179d9b2970aa6d41fe089 (patch)
tree58a77caf317a5597a54b8c8bf98b1424efe55e43
parentcargo.eclass: Optimize crate unpacking (diff)
downloadgentoo-6817a75995db17a403b179d9b2970aa6d41fe089.tar.gz
gentoo-6817a75995db17a403b179d9b2970aa6d41fe089.tar.bz2
gentoo-6817a75995db17a403b179d9b2970aa6d41fe089.zip
sys-fs/xfsprogs: remove libhandle.a when static-libs is disabled
Closes: https://bugs.gentoo.org/725538 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.7.0-r3.ebuild (renamed from sys-fs/xfsprogs/xfsprogs-6.7.0-r2.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-6.7.0-r2.ebuild b/sys-fs/xfsprogs/xfsprogs-6.7.0-r3.ebuild
index 6781e5f02997..dfca5f7562c5 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.7.0-r2.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.7.0-r3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="icu libedit nls selinux"
+IUSE="icu libedit nls selinux static-libs"
RDEPEND="
dev-libs/inih
@@ -92,4 +92,8 @@ src_install() {
# XXX: There's a missing dep in the install-dev target, so split it
emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install
emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install-dev
+
+ if ! use static-libs; then
+ rm "${ED}/usr/$(get_libdir)/libhandle.a" || die
+ fi
}