summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-05 10:20:51 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-05 10:21:31 +0200
commit6827e62a79980e3a9b4225ac2acbf5148d59b982 (patch)
tree79438d16f432e989b1afde1c747420fcf49e8324
parentgnome-base/dconf-editor: fix LICENSE (diff)
downloadgentoo-6827e62a79980e3a9b4225ac2acbf5148d59b982.tar.gz
gentoo-6827e62a79980e3a9b4225ac2acbf5148d59b982.tar.bz2
gentoo-6827e62a79980e3a9b4225ac2acbf5148d59b982.zip
gnome-base/dconf-editor: bump to 3.28.0
Most importantly (to me), this version adds proper relocatable schemas support. 3.30.x requires vala:0.40 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.28.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index b7a9f3d6b4b9..2b9433e58ef0 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1 +1,2 @@
DIST dconf-editor-3.26.2.tar.xz 542828 BLAKE2B e7bd35b39d7b0124105513d44f3a24d005f1c6daf2dccb1d3eeb324b65038adfc11e5ee83078058489b1e918222538a97621c74fb0a0ceb20e1a708ccf5a82bd SHA512 25a6536c97b4f6fc26890915e2d0ed3ff1d2247175fd25a7d86e44f33da8667064415b22890c799d3586cd0f08becc90414f02bf3d988aa1d02eee90d7e45ba5
+DIST dconf-editor-3.28.0.tar.xz 417244 BLAKE2B 1237b199b7b991055fe30829dff0554be7e3122001c9c1a3bd1b17dc1aeeb0a4df6536560b072559c96d4da0b26bdf234479cb9c38ae979d08c220348df48649 SHA512 435c159fd3356c19e459ed9441671b508c5ba1b2d9f491d304280ef66b980779fda5769bb2e1e85a294ceebe9e729e4899ac0ab750f86e5ccdbdc455cf1ffc44
diff --git a/gnome-base/dconf-editor/dconf-editor-3.28.0.ebuild b/gnome-base/dconf-editor/dconf-editor-3.28.0.ebuild
new file mode 100644
index 000000000000..73be2e331ae5
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.28.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.36"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://git.gnome.org/browse/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}