summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-10-10 13:28:46 -0400
committerBrian Dolbec <dolsen@gentoo.org>2020-10-10 14:56:12 -0400
commit6849b4da3c379a708ffeee0b84ce620079451d93 (patch)
tree87428e14d8ae7e78aa4a8fd1e9f3c80ad2edb3f5
parentdev-util/buildbot-grid-view: Version bump to 2.8.4 (diff)
downloadgentoo-6849b4da.tar.gz
gentoo-6849b4da.tar.bz2
gentoo-6849b4da.zip
dev-util/buildbot-wsgi-dashboards: Version bump to 2.8.4
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 036efb520e7b..5d52d05513f8 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1 +1,2 @@
DIST buildbot-wsgi-dashboards-2.8.2.tar.gz 5566 BLAKE2B 487b816862366acae9e55c39cb440a21c8e5c438299c43e2d6fad049ff946ece5ab647390955fbbad403ad1d7c0a2707a7612129442dc398cc7210d831aa49ef SHA512 2b75a61331aa457b3f168e1955b8905f95d11008ab6bee611ac92488f988cb0cf73fbf92321e594ac0a6e5ae03b82dfa05daab5a0647ae636a96922c0f4e8eff
+DIST buildbot-wsgi-dashboards-2.8.4.tar.gz 5588 BLAKE2B 3298edaebe2f9eb5e31f8298598e892d64d653648843e3c107710d4df3a24977bd3e77db06f7edecdf8d85bbbdeedfc66a75c6f3eef93ec8374d0df1973790dc SHA512 656f0626c8cad2c21d64ebc3eb4d6e1ac24a10909afc28819e54046be8e843a7383f3648a00a908cfddd9543767e1c3293825170d7c6c64c40a61bdcd55245bd
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild
new file mode 100644
index 000000000000..f124a0ef5c54
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"