summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-27 11:49:11 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-27 12:02:55 +0200
commit684b71d6ff28e69e2a876f280a613f15451846f9 (patch)
tree17362b0d80ea2518d73760ff0ed31e65d0b23f88
parentgnome-extra/nautilus-sendto: drop old revision (diff)
downloadgentoo-684b71d6.tar.gz
gentoo-684b71d6.tar.bz2
gentoo-684b71d6.zip
net-libs/libdmapsharing: version bump 2.9.37 → 2.9.39
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-libs/libdmapsharing/Manifest1
-rw-r--r--net-libs/libdmapsharing/libdmapsharing-2.9.39.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libdmapsharing/Manifest b/net-libs/libdmapsharing/Manifest
index 65e9d2199c6c..5ba3bbb0b752 100644
--- a/net-libs/libdmapsharing/Manifest
+++ b/net-libs/libdmapsharing/Manifest
@@ -1 +1,2 @@
DIST libdmapsharing-2.9.37.tar.gz 760469 SHA256 9b6847b4021596913c927cca51600727cd44582b4417a3b1ec6967d0ab42ec79 SHA512 db64c7e9ca6d8e06fdbec44853d8667a5d698244bc0881beae6aee447d464882accd885685636b3cd84735fe16eaa3b7bf692f2ac217525a9b86f5a12c810e8f WHIRLPOOL b8055b26a08417eb88950d35ab3c8c1bdbd26e86c0908edd65a4190e59f34a572731afd14b3283ed04311245e2c4731cbeeb4b6afd7d74ae6a50958ce2fecdbe
+DIST libdmapsharing-2.9.39.tar.gz 757492 SHA256 a90dc0681ae81700e46efc539f70edb6edd936b782a9a695434bea660a43a5ef SHA512 7003b947e1982735b647c1fa8e7e80e05322acf4ed4b5c1c28708da00a0bfe3eecac01bc2ddf59966e7db045f14fc78e749a2859d7e909bcea41164939f15b4a WHIRLPOOL 1d033a2ccc1d02ef1f4e916251c06b39a7ce52dc9c9b577a4a793518b41f4bef015ac654a8b3517a9539f0d6be671b245e7113b733ee4de5b1b630af837f8403
diff --git a/net-libs/libdmapsharing/libdmapsharing-2.9.39.ebuild b/net-libs/libdmapsharing/libdmapsharing-2.9.39.ebuild
new file mode 100644
index 000000000000..1f4570f41416
--- /dev/null
+++ b/net-libs/libdmapsharing/libdmapsharing-2.9.39.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A library that implements the DMAP family of protocols"
+HOMEPAGE="http://www.flyn.org/projects/libdmapsharing"
+SRC_URI="http://www.flyn.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="3.0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+# Vala/libgee/gtk+:2 is only used when maintainer-mode is enabled
+# Doesn't seem to be used for anything...
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ x11-libs/gdk-pixbuf:2
+ >=net-dns/avahi-0.6[dbus]
+ >=net-libs/libsoup-2.48.0:2.4
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.4 )
+"
+
+src_prepare() {
+ # Remove useless CFLAGS alteration in configure
+ sed -e 's/CFLAGS -O2/CFLAGS/' \
+ -i configure.ac configure || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-mdns=avahi \
+ $(use_enable introspection) \
+ $(use_enable test tests) \
+ $(use_enable test check)
+}