summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-08 09:30:28 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-08 09:30:28 +0200
commit68817d17313b7fbd6bf9080f38ec9608f3a2cb4e (patch)
tree634bdf9fec89ba878f4f8460f7f56715bb4b0ec3
parentdev-python/botocore: add 1.23.31 (diff)
downloadgentoo-68817d17.tar.gz
gentoo-68817d17.tar.bz2
gentoo-68817d17.zip
dev-python/boto3: add 1.20.31
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.31.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c6b54a81c102..49b42a9726f8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.20.24.tar.gz 456338 BLAKE2B 4192f20a7a5c247a72b381506697034d744fd62
DIST boto3-1.20.25.tar.gz 457371 BLAKE2B f1e6ab3add86f0ba25b22d92f58580e4ab86affdfb5c3b6f9a53938a2a647d0fc8cd23975cd60b909e5db339d442820e557497e232bda836ac9f2028b376afcf SHA512 2693134800ad3313785922c654296ca04a5b561e135fc60a45784e8190cdeb1dd525e6a81f314fda9f14f9dfddd5ffd8bde9af2d2be50b61921b9ec1248fee07
DIST boto3-1.20.26.tar.gz 458382 BLAKE2B a2123120c07bc8e53004f6c76f6631f3363d5d8e58057a08d2edf914d3a7ea1d2d6a771529abf7031604ac1c366a5b8ee4934e6d34d27eb3dd0716bc16cd6d22 SHA512 5ad18954f8347f240031c2dfab2664bf760b334b12ae90f1d2613f53194843f500164e645445d17fd4e7e7061beb3e2fe34a5a2651a92fdef5efecb18324cd36
DIST boto3-1.20.29.tar.gz 457663 BLAKE2B 8bb10de51a0250c3bf18b339ca6d9aa54985ebb0ff860862ced57ca1f0455f4c95834a689530e3bad043711735c22fee41e2e860602d7024bb8128ecaee7aa85 SHA512 c19e24a70d68919a2953a1f8060b519782a422183385276e0a439da2150fb20bf24e89153ecd9a134ee0fd631921569739aebf226815ca9c63244c8f2bc3c59a
+DIST boto3-1.20.31.tar.gz 458553 BLAKE2B 396acd8bbc47f76a0ba65da4b83f141f253690370f6cd36fcfad8b4ba1017889bb2c4c63bbcc8e3f817307cca666593072becde30b5739f38386f764a9f2c876 SHA512 0772959c735a6002431f171b6476398a1e1096301c20b5429504ed9a9bd6e3a2b6e95392504b3ea49ef942ab6c5210a0d26a0cdde6be52bb88d642ce776576b9
DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5793f8bfb210b52bbc09e39e6fe06a957951375e0795210dc1c3b2a0afd2f498bc88e449d9e6846f2b357f016 SHA512 2823466e4851684253d4ce42a8c34e5cbdad6d04c823040fe2cebdf0cffb14d5d3f40e28d57ebec14533fab04ba74f27c25f078ddb8791b8f52d0424e11b39fc
diff --git a/dev-python/boto3/boto3-1.20.31.ebuild b/dev-python/boto3/boto3-1.20.31.ebuild
new file mode 100644
index 000000000000..0d5810a8ffe0
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.31.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}