summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 13:35:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 14:18:22 +0100
commit688e3a013cb8b7decac8a5f827c3f396a0f0ac73 (patch)
tree97a0a2a60048e19cae9921d974373320b96c1571
parentdev-python/flaky: Strip nose plugin entry point as well (diff)
downloadgentoo-688e3a01.tar.gz
gentoo-688e3a01.tar.bz2
gentoo-688e3a01.zip
dev-python/setuptools_scm: Skip problematic test w/ nose installed
Closes: https://bugs.gentoo.org/892639 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
index 1efefeb1ff54..b4b66d2a3ea1 100644
--- a/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
+++ b/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
@@ -39,10 +39,21 @@ BDEPEND="
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # the usual nondescript gpg-agent failure
- testing/test_git.py::test_git_getdate_signed_commit
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the usual nondescript gpg-agent failure
+ testing/test_git.py::test_git_getdate_signed_commit
- # fetching from the Internet
- testing/test_regressions.py::test_pip_download
-)
+ # fetching from the Internet
+ testing/test_regressions.py::test_pip_download
+ )
+
+ if has_version dev-python/nose; then
+ EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/892639
+ testing/test_integration.py::test_pyproject_support
+ )
+ fi
+
+ epytest
+}