summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-12-21 23:00:41 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-12-21 23:01:27 +0700
commit6891faa4a5d8e70e28fc7faca054921acc2dd99e (patch)
tree1c7cfdd00fb2cdd191d4d208a0c04d48120e6e79
parentapp-misc/splitvt: Stabilize 1.6.6_p7 x86, #887673 (diff)
downloadgentoo-6891faa4a5d8e70e28fc7faca054921acc2dd99e.tar.gz
gentoo-6891faa4a5d8e70e28fc7faca054921acc2dd99e.tar.bz2
gentoo-6891faa4a5d8e70e28fc7faca054921acc2dd99e.zip
sci-visualization/gle: bump to 4.3.3
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--sci-visualization/gle/Manifest4
-rw-r--r--sci-visualization/gle/files/64gle-gentoo.el2
-rw-r--r--sci-visualization/gle/files/gle-4.3.3.patch134
-rw-r--r--sci-visualization/gle/files/gle.sh3
-rw-r--r--sci-visualization/gle/gle-4.3.3.ebuild82
5 files changed, 224 insertions, 1 deletions
diff --git a/sci-visualization/gle/Manifest b/sci-visualization/gle/Manifest
index e76fdeeb715c..77a35673c733 100644
--- a/sci-visualization/gle/Manifest
+++ b/sci-visualization/gle/Manifest
@@ -1 +1,5 @@
+DIST gle-4.3.3.tar.gz 1788614 BLAKE2B 3f608a8dad32d02b06808d5b2cfe4a2beb2c076c74e2972be2e94fe56bf24190b9cc7c69f45f1b02d399354f827c43722029871d6355bc0e4abe003f71b2bf82 SHA512 191dde025828f3376c7241e0580fcd459c743fe947f69cc3be1345b43c1d2587852a0d002dfdab7d8b7b45fd30e6bf4e8a4b5c73bcc2f3ce2fd08aa41d799b03
DIST gle-graphics-4.2.5f-src.tar.gz 2330270 BLAKE2B 46435a2366a278a88786a2dd0e0cbcc48d3ba2fc6d895fb07c81216089a10b2223b2ba692b951ee01a6ab014e84cce9aa3969d063ddf7d04501820aa33084c5c SHA512 d459b24577c9c3f8825c368f864532c97d0a37c94018276a60c941d17dce0e55fe738f7eda3227a47848f2fb32fea1dcec29d9751a5be92cde4d8d38a2eeb0f5
+DIST gle-library.tar.gz 1073620 BLAKE2B 051f9584dbf3195c7598ae54b12ab8d373e8054e8ff4c3d1dfed70319c29c5cb8bb1f0baff127768bcf9e36e4f52be3b3238e786e1598d1cdfbd6d1af6d6bdd3 SHA512 af6a46f2bd945714679eb9d8ca4c70ca9a741cf6652590eb3a8d9422059f49ce3d2c33418c37899bd54f9e0bc0085ae82ffd2f2b84b77879e2f2d09a0026d12a
+DIST gle-manual.pdf.gz 1878050 BLAKE2B 6ebd3c0214ab8aee3e5a32d1e1cdf1c001cd09325c80a506a1e41f4eb3ec8869b75083c741a5cf8b2f3faf1d2cb0c6cfeca835daa284263598f749109904cc11 SHA512 7cc796626fa19541558004250a4a5b206ead7ba704c76fd948693aca144e70926b8213ee8b062841bffedc631eb39a255d69387bbee4a5acc7edc6d093e3113f
+DIST gle-mode.el.gz 7359 BLAKE2B bcbc61651f87f3ee1d079fc0a0de38788523a5ee33f56087b89f4e15b9ef5ee4010cf47679c38da3dfae1954ddbfee4728d10c0af6530f645ff63ab2b219da09 SHA512 c8d291c23f53346d8a44b7d95d737da88c6ec0af597fb8298a564a5567a9e9a0db658d14c3cb43157d58614e65cf2293eaeb01528a7a49722a2da07e16f940e1
diff --git a/sci-visualization/gle/files/64gle-gentoo.el b/sci-visualization/gle/files/64gle-gentoo.el
index 841503ba6eec..6c60d91fd302 100644
--- a/sci-visualization/gle/files/64gle-gentoo.el
+++ b/sci-visualization/gle/files/64gle-gentoo.el
@@ -2,5 +2,5 @@
;;; gle site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
-(autoload 'gle-mode "gle-mode")
(add-to-list 'auto-mode-alist '("\\.gle\\'" . gle-mode))
+(autoload 'gle-mode "gle-mode" "Major mode for gle files." t)
diff --git a/sci-visualization/gle/files/gle-4.3.3.patch b/sci-visualization/gle/files/gle-4.3.3.patch
new file mode 100644
index 000000000000..22dc0b160605
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.3.3.patch
@@ -0,0 +1,134 @@
+diff -r -U2 src.orig/CMakeLists.txt src/CMakeLists.txt
+--- src.orig/CMakeLists.txt 2022-04-14 02:47:12.000000000 +0700
++++ src/CMakeLists.txt 2022-12-20 13:03:11.386586253 +0700
+@@ -9,4 +9,7 @@
+ project (gle VERSION 4.3.3)
+
++set(CMAKE_CXX_STANDARD 14)
++set(CMAKE_CXX_STANDARD_REQUIRED ON)
++
+ add_compile_definitions(GLEVN="${PROJECT_VERSION}")
+ set( CMAKE_DEBUG_POSTFIX "d")
+@@ -130,5 +133,5 @@
+ string(COMPARE NOTEQUAL "${CAIRO_LIBRARIES}" "CAIRO_LIBRARIES-NOTFOUND" CAIRO_FOUND)
+ endif()
+-find_path(CAIRO_INCLUDE_DIRS cairo.h PATHS ${CAIRO_ROOT} PATH_SUFFIXES include REQUIRED)
++find_path(CAIRO_INCLUDE_DIRS cairo.h PATHS ${CAIRO_ROOT} PATH_SUFFIXES include include/cairo REQUIRED)
+ if(CAIRO_FOUND)
+ message("-- Found CAIRO: " ${CAIRO_LIBRARIES} )
+@@ -154,8 +157,8 @@
+ endif()
+ else()
+- find_library(PIXMAN_LIBRARIES NAMES pixman pixmand PATHS ${PIXMAN_ROOT} PATH_SUFFIXES lib REQUIRED)
++ find_library(PIXMAN_LIBRARIES NAMES pixman pixmand pixman-1 PATHS ${PIXMAN_ROOT} PATH_SUFFIXES lib lib64 REQUIRED)
+ string(COMPARE NOTEQUAL "${PIXMAN_LIBRARIES}" "PIXMAN_LIBRARIES-NOTFOUND" PIXMAN_FOUND)
+ endif()
+-find_path(PIXMAN_INCLUDE_DIRS pixman.h PATHS ${PIXMAN_ROOT} PATH_SUFFIXES include REQUIRED)
++find_path(PIXMAN_INCLUDE_DIRS pixman.h PATHS ${PIXMAN_ROOT} PATH_SUFFIXES include include/pixman-1 REQUIRED)
+ if(PIXMAN_FOUND)
+ message("-- Found PIXMAN: " ${PIXMAN_LIBRARIES} )
+@@ -164,9 +167,9 @@
+ # -- GHOSTscript or GHOSTPDL include directory only since gle links to installed version at runtime
+ #
+-find_path(GDIR1 iapi.h PATHS ${GHOSTPDL_ROOT} PATH_SUFFIXES psi base devices )
++find_path(GDIR1 iapi.h PATHS ${GHOSTPDL_ROOT} PATH_SUFFIXES psi base devices ghostscript )
+ list(APPEND GHOSTPDL_INCLUDE_DIRS ${GDIR1} )
+-find_path(GDIR2 gdevdsp.h PATHS ${GHOSTPDL_ROOT} PATH_SUFFIXES psi base devices )
++find_path(GDIR2 gdevdsp.h PATHS ${GHOSTPDL_ROOT} PATH_SUFFIXES psi base devices ghostscript )
+ list(APPEND GHOSTPDL_INCLUDE_DIRS ${GDIR2} )
+-find_path(GDIR3 gserrors.h PATHS ${GHOSTPDL_ROOT} PATH_SUFFIXES psi base devices )
++find_path(GDIR3 gserrors.h PATHS ${GHOSTPDL_ROOT} PATH_SUFFIXES psi base devices ghostscript )
+ list(APPEND GHOSTPDL_INCLUDE_DIRS ${GDIR3} )
+
+@@ -398,5 +401,4 @@
+ # documentation file installation in doc folder
+ install(FILES
+- ../doc/LICENSE.txt
+ ../doc/README.txt
+ ../doc/ChangeLog.txt
+diff -r -U2 src.orig/gui/CMakeLists.txt src/gui/CMakeLists.txt
+--- src.orig/gui/CMakeLists.txt 2022-04-14 02:47:12.000000000 +0700
++++ src/gui/CMakeLists.txt 2022-12-19 10:21:59.026388957 +0700
+@@ -54,11 +54,14 @@
+ $<$<PLATFORM_ID:Windows>:qgle.rc>
+ )
+-# no jpeg as its contianed in Qt
++# no jpeg as its contained in Qt
++# but need to add JPEG for Debian!
++# order matters: first static files (and libgle), then dynamic libraries
+ target_link_libraries ( qgle LINK_PUBLIC
++ libgle-graphics_s
+ ${ZLIB_LIBRARIES}
++ ${JPEG_LIBRARIES}
+ ${TIFF_LIBRARIES}
+ ${PNG_LIBRARIES}
+ ${PIXMAN_LIBRARIES}
+- libgle-graphics_s
+ Qt::Core
+ Qt::Gui
+@@ -70,5 +73,6 @@
+
+ if(UNIX AND NOT APPLE)
+- target_link_libraries ( qgle LINK_PUBLIC
++ target_link_libraries ( qgle LINK_PUBLIC
++ dl
+ glut
+ GLU
+diff -r -U2 src.orig/gui/main.cpp src/gui/main.cpp
+--- src.orig/gui/main.cpp 2022-04-14 02:47:12.000000000 +0700
++++ src/gui/main.cpp 2022-12-19 10:21:59.046388957 +0700
+@@ -277,5 +277,5 @@
+ #endif
+ #ifdef Q_OS_LINUX
+- Q_IMPORT_PLUGIN(QWaylandIntegrationPlugin)
++ // Q_IMPORT_PLUGIN(QWaylandIntegrationPlugin)
+ #endif
+ QLocale curLocale("C");
+diff -r -U2 src.orig/gui/qgs.h src/gui/qgs.h
+--- src.orig/gui/qgs.h 2022-04-14 02:47:12.000000000 +0700
++++ src/gui/qgs.h 2022-12-19 10:21:59.068388958 +0700
+@@ -40,7 +40,7 @@
+ #include "gsinc/ierrors.h"
+ #else
+-#include <ierrors.h>
+-#include <iapi.h>
+-#include <gdevdsp.h>
++#include <ghostscript/ierrors.h>
++#include <ghostscript/iapi.h>
++#include <ghostscript/gdevdsp.h>
+
+ #endif
+diff -r -U2 src.orig/makefmt/makefmt.cpp src/makefmt/makefmt.cpp
+--- src.orig/makefmt/makefmt.cpp 2022-04-14 02:47:12.000000000 +0700
++++ src/makefmt/makefmt.cpp 2022-12-18 14:09:54.399896247 +0700
+@@ -115,6 +115,6 @@
+
+ int main(int argc, char *argv[]) {
+- char filename[80];
+- char fmtname[80];
++ char filename[200];
++ char fmtname[200];
+ init_accents();
+ /* encoding file given? */
+diff -r -U2 src.orig/TeX/CMakeLists.txt src/TeX/CMakeLists.txt
+--- src.orig/TeX/CMakeLists.txt 2022-04-14 02:47:12.000000000 +0700
++++ src/TeX/CMakeLists.txt 2022-12-20 13:34:00.953502995 +0700
+@@ -52,11 +52,11 @@
+ )
+ # make the inittex.ini in the install folder
+-install(CODE "execute_process(COMMAND ${CMAKE_INSTALL_PREFIX}/bin/gle$<$<CONFIG:Debug>:d> -mkinittex)")
++# install(CODE "execute_process(COMMAND ${CMAKE_INSTALL_PREFIX}/bin/gle$<$<CONFIG:Debug>:d> -mkinittex)")
+ # explicity install inittex.ini for cpack even though its created in this directory
+ # from gle -mkinittex command above
+-install(FILES
+- ${CMAKE_INSTALL_PREFIX}/inittex.ini
+- CONFIGURATIONS Release Debug
+- DESTINATION .
+-)
++# install(FILES
++# ${CMAKE_INSTALL_PREFIX}/inittex.ini
++# CONFIGURATIONS Release Debug
++# DESTINATION .
++# )
+
+Только в src/TeX: CMakeLists.txt~
diff --git a/sci-visualization/gle/files/gle.sh b/sci-visualization/gle/files/gle.sh
new file mode 100644
index 000000000000..38fb09ada2fa
--- /dev/null
+++ b/sci-visualization/gle/files/gle.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+export GLE_TOP=/usr/share/gle
+exec /usr/bin/gle.bin $*
diff --git a/sci-visualization/gle/gle-4.3.3.ebuild b/sci-visualization/gle/gle-4.3.3.ebuild
new file mode 100644
index 000000000000..cb055d4ec0fb
--- /dev/null
+++ b/sci-visualization/gle/gle-4.3.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake elisp-common
+
+DESCRIPTION="Graphics Layout Engine"
+HOMEPAGE="http://glx.sourceforge.io/ https://github.com/vlabella/GLE/"
+IUSE="doc emacs"
+LIB_VERSION="d476418f006b001dc7f47dcafb413c0557fa44a7"
+SRC_URI="https://github.com/vlabella/GLE/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vlabella/gle-library/archive/${LIB_VERSION}.tar.gz -> ${PN}-library.tar.gz
+ doc? ( https://dev.gentoo.org/~grozin/gle-manual.pdf.gz )
+ emacs? ( https://dev.gentoo.org/~grozin/gle-mode.el.gz )"
+S="${WORKDIR}"/GLE-${PV}/src
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="app-text/ghostscript-gpl
+ dev-libs/boost
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ media-libs/libpng
+ media-libs/tiff
+ sys-libs/zlib
+ media-libs/libjpeg-turbo
+ x11-libs/cairo
+ x11-libs/pixman
+ emacs? ( app-editors/emacs:* )"
+RDEPEND="${DEPEND}
+ virtual/latex-base"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )
+SITEFILE="64${PN}-gentoo.el"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLE_EXAMPLES_LIBRARY_PATH="${WORKDIR}"/gle-library-${LIB_VERSION}
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use emacs && elisp-compile "${WORKDIR}"/*.el
+}
+
+src_install() {
+ pushd "${WORKDIR}"/${P}_build > /dev/null || die "pushd failed"
+ newbin gle/gle gle.bin
+ dobin gui/qgle
+ insinto /usr/share/${PN}
+ doins gle/glerc
+ doins -r gle/font
+ popd > /dev/null
+ newbin "${FILESDIR}"/gle.sh gle
+ dodoc ../doc/README.txt ../doc/ChangeLog.txt
+ doins TeX/init.tex
+ mv "${WORKDIR}"/gle-library-${LIB_VERSION}/include "${WORKDIR}"/gle-library-${LIB_VERSION}/gleinc || die "mv failed"
+ doins -r "${WORKDIR}"/gle-library-${LIB_VERSION}/gleinc
+ GLE_TOP="${D}"/usr/share/${PN} "${D}"/usr/bin/gle.bin -mkinittex
+ use doc && dodoc "${WORKDIR}"/*.pdf
+ if use emacs; then
+ elisp-install ${PN} "${WORKDIR}"/*.el "${WORKDIR}"/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}