summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-01-03 12:01:08 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-01-03 12:01:08 +0700
commit68e52694d4f2e34469c9285f68eccff6a48e12cc (patch)
treeaf1c8a59c264b420f048fe8e9d9ac3796e232432
parentapp-text/pdfarranger: bump to 1.8.2 (diff)
downloadgentoo-68e52694.tar.gz
gentoo-68e52694.tar.bz2
gentoo-68e52694.zip
dev-util/diffuse: bump to 0.7.3
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--dev-util/diffuse/Manifest1
-rw-r--r--dev-util/diffuse/diffuse-0.7.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/diffuse/Manifest b/dev-util/diffuse/Manifest
index 9ac73c226f8f..09d19566b88a 100644
--- a/dev-util/diffuse/Manifest
+++ b/dev-util/diffuse/Manifest
@@ -1,2 +1,3 @@
DIST diffuse-0.6.0.tar.gz 621120 BLAKE2B c39cbe55edb6e1734d4db1343a0b0029ab146fe92ef4edc58cd6ea82bc6780e3f789d6765d2bddecd941fa458781c59ddde71a010f1b90d4ca238e6d6b233dc2 SHA512 fe9842738560dbefe9c546c8bba3f9f1cefcf4c327ad644430c512ec6bb1b4877986ca2b816af75226975eefa9b0f70120a4ed574e2ed90058b0a92380e8995a
DIST diffuse-0.7.2.tar.gz 512468 BLAKE2B 82d9e13399fe775ae7d901198fca4bcc596914cbc5b2b52497a68292d78298346f51caa2031704858cfc770c7cbd6cb6ce1648fc2df7a674db71041c6abbf1ee SHA512 86488cf5a22b791c036de7299c0cd95e63de0bb26d89080c785972341144e72b006910860652190ff250fa5ecad6c7fac64aa3fe90035eda42b923650e292b76
+DIST diffuse-0.7.3.tar.gz 519865 BLAKE2B 2980e919cd3fb5c88fef631f83fe6587511791a7fb63cf9b3b7c6b08445baac2f59811a516bb01cad0f2d30d11e113de5c672f26f7d1a17322c711d1ffeaa42d SHA512 b490ba761375092b759daf2e2a89fd0ad3e69d3043487d82c0635c2d35d1ebdad5e32922e53ff3496684e8b02ea8e1f123313d891695e9b0647a775c12b80ea7
diff --git a/dev-util/diffuse/diffuse-0.7.3.ebuild b/dev-util/diffuse/diffuse-0.7.3.ebuild
new file mode 100644
index 000000000000..b2550df09ec4
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.7.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PLOCALES="cs de es it ja ko pl pt pt_BR ru sv th zh_CN zh_TW"
+inherit meson plocale python-r1 xdg
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/ https://github.com/MightyCreak/diffuse/"
+SRC_URI="https://github.com/MightyCreak/diffuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ ')
+ x11-libs/gtk+:3[introspection]"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ default
+ plocale_find_changes po '' '.po'
+
+ rm_locale() {
+ rm -f po/${1}.po
+ rm -rf data/usr/share/man/${1}
+ rm -rf data/usr/share/gnome/help/${PN}/$1
+ rm -f data/usr/share/omf/${PN}/${PN}-$1.omf
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_locale
+}
+
+src_install() {
+ meson_src_install
+ rm "${D}"/usr/bin/${PN} || die "rm ${PN} failed"
+ python_foreach_impl python_doscript ../${P}-build/src/${PN}/${PN}
+ mkdir "${D}"/usr/share/metainfo || die "mkdir metainfo failed"
+ mv "${D}"/usr/share/appdata/* "${D}"/usr/share/metainfo/ \
+ || die "mv appdata -> metainfo failed"
+ dodoc AUTHORS CHANGELOG.md README.md
+}