summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-09-21 15:25:36 +0200
committerMatt Turner <mattst88@gentoo.org>2022-09-21 22:56:02 -0400
commit68e7792528767ad3cf99374135970d847e8b2d6b (patch)
tree94f7b423c1ce5fe0a244ea28f855b9e7fbf1373c
parentx11-themes/gnome-backgrounds: Version bump to 43 (diff)
downloadgentoo-68e77925.tar.gz
gentoo-68e77925.tar.bz2
gentoo-68e77925.zip
app-office/gnumeric: bump to 1.12.53
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.53.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 470816fe06d8..7d3875bf9608 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.52.tar.xz 18115444 BLAKE2B 6d8489c27b6f7bd0ffad7d255b606a48ca9660dd38973e4bb529d38797a3029db4a0a399e40f69c84ddf33b96d27cfc184fd079fbe16590b92e056c1a836b037 SHA512 3baa2d2c4ed5f740429454f988ea527991febf38f49df17f0d88affe501c676bae95149fb0cdb4b369ef8d32247c1f4fe4c0eeab9a60329e1332aaf9c566f868
+DIST gnumeric-1.12.53.tar.xz 18125272 BLAKE2B 6c25107977492391152c403d2ad6fef79161bc9045660090e12cdd281e5832b4f9e414a0ef5e67f93c10ca789097b510fafed712dcea5b6210f67428a2dc7dd7 SHA512 6e9d7b12f9448c75d39985984fac9880c61583fbac10ad9070f5ec7a5bd573874d79e13372d9a185616a5cdb5f53d3f67aeda6ca4bae33e3f5ca0a2160045d7b
diff --git a/app-office/gnumeric/gnumeric-1.12.53.ebuild b/app-office/gnumeric/gnumeric-1.12.53.ebuild
new file mode 100644
index 000000000000..2f621517609c
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.53.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit autotools gnome.org python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.51:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+
+ # Changed from 'elibtoolize' for bug # 791610
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}