summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-27 21:05:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-27 21:08:54 -0400
commit68f29b36abe7cdd02ce86955b8e6e00c23a36485 (patch)
treec0264bf59b46f6bf45e4932e2f21b86998ba6b85
parentmedia-plugins/gst-plugins-libnice: add 0.1.21 (diff)
downloadgentoo-68f29b36abe7cdd02ce86955b8e6e00c23a36485.tar.gz
gentoo-68f29b36abe7cdd02ce86955b8e6e00c23a36485.tar.bz2
gentoo-68f29b36abe7cdd02ce86955b8e6e00c23a36485.zip
app-emulation/ruffle: skip displacement_map tests + use xdg reset
Note that this skips all 4 failing tests, it's matching on substring. Closes: https://bugs.gentoo.org/911320 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-emulation/ruffle/ruffle-0_p20230724.ebuild11
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild11
2 files changed, 20 insertions, 2 deletions
diff --git a/app-emulation/ruffle/ruffle-0_p20230724.ebuild b/app-emulation/ruffle/ruffle-0_p20230724.ebuild
index e242da6b322b..012ed52e5f0f 100644
--- a/app-emulation/ruffle/ruffle-0_p20230724.ebuild
+++ b/app-emulation/ruffle/ruffle-0_p20230724.ebuild
@@ -615,7 +615,16 @@ src_configure() {
}
src_test() {
- virtx cargo_src_test
+ xdg_environment_reset
+
+ local skip=(
+ # this should be fine on real hardware, but currently fails with mesa's
+ # software rendering (bug #911320) -- note they are auto-skipped if
+ # USE=-gles2 on mesa, and this just forces to skip regardless
+ --skip visual/filters/displacement_map
+ )
+
+ virtx cargo_src_test -- "${skip[@]}"
}
src_install() {
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 4fb5bd694470..ced4e9790b1e 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -80,7 +80,16 @@ src_configure() {
}
src_test() {
- virtx cargo_src_test
+ xdg_environment_reset
+
+ local skip=(
+ # this should be fine on real hardware, but currently fails with mesa's
+ # software rendering (bug #911320) -- note they are auto-skipped if
+ # USE=-gles2 on mesa, and this just forces to skip regardless
+ --skip visual/filters/displacement_map
+ )
+
+ virtx cargo_src_test -- "${skip[@]}"
}
src_install() {