summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 18:40:35 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 18:40:35 +0200
commit6903e4be6697be4987f83c05268e05c927262eb2 (patch)
tree556f264478e90d85883e0c84d134d3173a9334ac
parentgnome-extra/gnome-calculator: Drop old (diff)
downloadgentoo-6903e4be.tar.gz
gentoo-6903e4be.tar.bz2
gentoo-6903e4be.zip
gnome-extra/gnome-calculator: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--gnome-extra/gnome-calculator/Manifest1
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.20.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calculator/Manifest b/gnome-extra/gnome-calculator/Manifest
index 395fbd64ede2..c46f409eedf2 100644
--- a/gnome-extra/gnome-calculator/Manifest
+++ b/gnome-extra/gnome-calculator/Manifest
@@ -1 +1,2 @@
DIST gnome-calculator-3.18.3.tar.xz 1339496 SHA256 c376a4a14a3f7946b799b8458ac4cf2694735fc7c20e90cfda29e209439e32ff SHA512 74ee2e22dc199a1beb8526bfa11174caaaeed0c2568f5e122f1c1c7f09b75926d30b5bdfa61a1e8495de9c2a449ee632e62fbbc11c04d5c44c83f819a6c409b5 WHIRLPOOL c371233a98ec28a3aa2a956d69b834a97508e0d6a58a43f918ca1d992b7efb434533926cd2d72a610c1c00cfbb101139c1db44a7771549da463c882cc0702c98
+DIST gnome-calculator-3.20.1.tar.xz 1454768 SHA256 02edcf99857599ac10ecd2faaf33ad20a9f11f7c5a89a52ee1b511d99b594b90 SHA512 28198343422d61eec40938e35659e92bec1a67c4a6f16bdafd7a13f0b3a449d884f33daa9cf6c61bd56e9859ae3554522a02c0650ffcfaf64fb69b69671e347e WHIRLPOOL 51940f923548c9a262d03dea1d263e4b11112e6f92e1b0616947ca10fb8e50ce2425abff2baf76b934585e22ca5f81e3a99e433ca535949ed2121975a5415230
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.20.1.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.20.1.ebuild
new file mode 100644
index 000000000000..230f3711c8d6
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.20.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/gtksourceview-3.15.1:3.0
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-utils-2.3
+ !gnome-extra/gcalctool
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ VALAC=$(type -P true)
+}