summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-30 08:40:54 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-30 08:40:54 +0100
commit691dca6b4645df597ca1d7b18aa554240f2c78b3 (patch)
tree17a23fc6c3d37323bdc54f185252af4a6cc8db96
parentdev-ruby/diff-lcs: enable ruby33 (diff)
downloadgentoo-691dca6b4645df597ca1d7b18aa554240f2c78b3.tar.gz
gentoo-691dca6b4645df597ca1d7b18aa554240f2c78b3.tar.bz2
gentoo-691dca6b4645df597ca1d7b18aa554240f2c78b3.zip
dev-ruby/rspec-support: enable ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.12.1.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-ruby/rspec-support/rspec-support-3.12.1.ebuild b/dev-ruby/rspec-support/rspec-support-3.12.1.ebuild
index fd5760ca30c8..7a33ee949ce0 100644
--- a/dev-ruby/rspec-support/rspec-support-3.12.1.ebuild
+++ b/dev-ruby/rspec-support/rspec-support-3.12.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -42,14 +42,11 @@ each_ruby_prepare() {
sed -i -e '/shell_out/ s:ruby:'${RUBY}':' spec/rspec/support/spec/shell_out_spec.rb || die
case ${RUBY} in
- *ruby31|*ruby32)
+ *ruby31|*ruby32|*ruby33)
# Avoid specs failing when run in Gentoo, possibly due to different IO
sed -e '/outputs unified diff message of two arrays/askip "ruby31 IO"' \
-e '/outputs unified diff message for hashes inside arrays with differing key orders/askip "ruby31 IO"' \
-i spec/rspec/support/differ_spec.rb || die
-
- # Avoid specs broken on newer ruby versions and already pending upstream
- rm -f spec/rspec/support/reentrant_mutex_spec.rb
;;
esac
}